0

Test video https://twitter.com/NHL/status/740577888735526912. In Chromium

enter image description here

Unsuccessfuly attempts

  • I followed the guide here > https://get.adobe.com/flashplayer/ > 64 bit apt Ubuntu 10+. After install, I get the notice you already have the plugin.
  • masi@masi:~$ sudo apt-get install adobe-flash-properties-gtk
  • masi@masi:~$ sudo apt-get install adobe-flashplugin

In Firefox, the .swf files work with the plugin browser-plugin-gnash however.

Internal differences of two systems - Ubuntu's glue!

Please, see my answer about Debian 8.5 for the case where the hardware is more stable: Asus Zenbook UX303UA. The solution works with only a single package in Debian, while Ubuntu requires also the second package. This proposes me that there is something internal going on in Ubuntu, which should be profiled and fixed.

Flash Player: gnash 0.8.11
Internet browser: Chromium, 51.x, Google Chrome 52.x
System: Ubuntu 16.04 64 bit
Hardware: Macbook Air 2013-mid

2

Gnash can't work with Chromium. Uninstall it first before doing the following installation. The solution is to install Google's PepperFlash plugin (disclaimer: nonfree) and the freshplayer component:

sudo apt install pepperflashplugin-nonfree browser-plugin-freshplayer-pepperflash
  • Please, see my answer below. I managed to solve the case without your first package in Debian 8.5. Note that you need both packages in Ubuntu 16.04. There is something internal going on, possibly wrong, in Ubuntu, because you need such fixes there but not in Debian. – Léo Léopold Hertz 준영 Sep 7 '16 at 11:14
  • I really want to understand why the situation can be solved by one package only. Note that the first package is removed from Debian's apt-get also. – Léo Léopold Hertz 준영 Sep 7 '16 at 11:24
0

Solution in Debian 8.5. Do as root where the first package of Raju's answer does not exist in Debian, but the following command works there without the package

apt-get install browser-plugin-freshplayer-pepperflash

Test videos: NHL video about Joonas Donskoi, here in Finnish main media
Hardware: Asus Zenbook UX303UA
OS: Debian 8.5 64 bit
Linux kernel: 4.6 (backports)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.