5

I do

find /media/masi/FAT32/ -type f -name '._*' -delete

but I get

find: cannot delete '/media/masi/FAT32/._booklet.pdf': Read-only file system

I do not know how to work with such situations when working in ext4 but searching fat32. There are no permissions/owners in fat32. So I would like to change that all read-write all files in the memory card. However, not sure if it can be done here. It can also be a file system consistency problem but not sure. I just noticed many .dotFiles in the system, which seems to be backup files because I did not use the option described here before. I do ls -la /media/masi/

drwxr-xr-x 29 masi masi 32768 1 1970 FAT32

I do mount -o remount, rw /media/masi/FAT32/ but I get

mount: mount point /media/masi/FAT32/ does not occur

Command dmesg | grep FAT32 gives blank. Command lsblk also does not show the memory. Profiling the memory in Nautilus of Debian 8.25 where I see the main node correctly but subnodes not; in terminal, I can however search the tree but not sure how good it is

Sorry, could not display all the contents of “handouts.noindex”: Error when getting information for file '/media/masi/FAT32/handouts.noindex/╖Yp╟@≥3.ç╜╩': Input/output error

Memory: Transcend JetDrive Lite 130 128 GB (for Macbook Air 2013-mid)
Hardware: Macbook Air 2013-mid and Dell PC i3 2013
OS: Ubuntu 16.04 and Debian 8.5

  • 1
    @Masi I don't see that you say other file in filesystem are read-write (file permission are not useful). Also I have difficulties to understand your question, because in text it seems that you are asking an other question. So I think you should start checking mount options. – Giacomo Catenazzi Jun 9 '16 at 13:23
  • 2
    @Masi you can't tell if filesystem is RW by looking at ls, type mount | grep FAT32 and paste the output. Actually your filesystem is mounted read-only, I somehow missed the Read-only file system in your error. Just run mount -o remount,rw /media/masi/FAT32 – Hesham Ahmed Jun 9 '16 at 13:28
  • 4
    try to remount as read-write the filesystem....mount -o remount, rw /media/masi/FAT32/ . As the error mentioned, the filesystem is read-only – mazs Jun 9 '16 at 13:29
  • 1
    The access to a VFAT partition often gets implicitly set to RO when there are access/read errors. Try fscking your drive, and format it if that doesn't help. – Murphy Jun 10 '16 at 12:32
  • 1
    RO stands for read-only, in contrast to RW (read-write) access. Better try fsck.vfat /dev/... to see if any problems exist at all, then add the -a option to repair them. And before try to save valuable data from the drive, as you might loose the content in the process. – Murphy Jun 10 '16 at 12:43
7

The access to a VFAT partition often gets implicitly set to read-only when there are access/read errors. In order to check and solve these try the following steps. Be aware to use the right device, else you can damage your system!

  1. Try to save valuable data from the drive by copying it to some other drive or your home directory.
  2. Unmount the drive.
  3. Check for problems with sudo fsck.vfat /dev/...
  4. If fsck reports errors, try to repair them: sudo fsck.vfat -a /dev/....
    For more thorough checks see also the -t and -V options, as well as -f to try saving the content of damaged files.
  5. After fsck has finished you can remove and reconnect the drive and try again to access it.
  6. If that doesn't help, try to format the drive: sudo mkfs.vfat /dev/....
  7. If that still doesn't help, or the problem reoccurs, the drive may be damaged badly and should be discarded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.