4

My problem started yesterday, when I installed LMDE for the first time. Everything ran smoothly, up until I got to configuring my wireless. The first wireless network was a breeze to configure. I was able to join and it worked fine. That day, when I went to school... I found I was unable to actually join any other networks. If I selected a network in the list, it would unselect itself.

I eventually diagnosed the problem as the fact that it was always trying to join my home network. The file at etc/NetworkManager/system-connections was labeled "AUTO (My home network's name)"... so, using 'sudo rm etc/NetworkManager/system-connections/"Auto (My home network's name)" ', I removed that file hoping it would fix my issue.

What I found, however is that the problem has persisted through this "fix", and I can still not join any networks.

I found the Network Connections app, and when I went to the "Wireless" tab, then hit the "Add network" button... all the options are blanked out. If I use the "echo $UID" prompt, I am told I am the first user (user 1000) on the disk... so I'm at a loss.

Is there any way of reconfiguring my wireless files all over again, or regaining control of my Network Connections application?

  • Are you using Cinnamon/MATE/something else as your DE, are you wanting to configure through a GUI or by writing NetworkManager configuration yourself ... have you read the man pages on NM? Tried nmcli? – pbhj Jun 10 '17 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.