With a fresh Windows 10 machine (Lenovo H50-55) I did a dual-boot install with Fedora 23. The installation seemed to go fine, but when I rebooted it went straight to Windows as if there was no GRUB. When I used Boot-Repair it found both Windows and Fedora on the machine, and its "repair" option chugged away, but it didn't fix the problem after a reboot; in fact, in comparing the Boot Info files from before and after the repair attempt it seems there wasn't really any changes.

EDIT: I also encountered the same problem after upgrading my machine's BIOS.


I followed these instructions from It's F.O.S.S. to use bcdedit in an admin-priveledged command prompt, but with a slightly different path since it was Fedora instead of Ubuntu:

bcdedit /set {bootmgr} path \EFI\fedora\grubx64.efi

When I next rebooted I got to GRUB, which allowed me to boot into either Fedora or Windows.

EDIT: The same solution also worked after GRUB was ignored after upgrading my machine's BIOS.


Some new laptop has new features which is secure boot. Disable it from bios and boot the system. More information can be find at https://blog.malwarebytes.org/security-world/2014/05/uefi-secureboot-and-dual-booting-windows-8-and-linux/

  • I'd tried disabling secure boot, it didn't help. – Matthew Cline Jun 8 '16 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.