0

After rebooting computer I can't log in to desktop as anything else than "root". If I try with my normal username and correct password the screen blinks and returns without any message or anything.

Q: How do I get back to the desktop as a normal user?

Here's what I did before this happened:

I'm using Intel onboard graphics and while browsing software in Synaptic I found the "xserver-xorg-video-intel" driver. It says:

"The use of this driver is discouraged if your hw is new enough (ca. 2007 and newer). You can try uninstalling this driver and let the server use it's builtin modesetting driver instead."

So I uninstalled it.

During the same session I also went to the terminal and ran Xorg -configure. And as SU I issued "startx" and ended up in a new GUI session for root, which I didn't really intended.

Before that I also tried to setmode 1920x1080 for my monitor, which failed and I had to accept 1600x1200

(Using Debian 8)

EDIT: Noticed now that if I at the Display Manager press CTRL+ALT+F1 and jump to terminal and log in as my usual user and issue: startx, nothing seems to happen, but hitting CTRL+C 4-5 times sends me into the desktop for my user. Logging out and trying to log in the normal way still doesn't work.

0

I think you will see errors in journalctl, or possibly ~/.xsession-errors.

Something like what you describe might cause a permissions error. Try running the command chown -R user:user ~user/.??* as root. It should fix permissions on all "hidden" files used to configure your session. May take some time if that includes a large Thunderbird^WIcedove cache.

  • This fixed the problem and you were right about errors in journalctl: lightdm[481]: Error writing X authority: Failed to open X authority /home/user/.Xauthority: Permission denied – Rimfire Jun 7 '16 at 19:30
1

Maybe I'm wrong, but to me this sounds like a login loop caused by lack of ownership of the file ~/.Xauthority. This file normally belongs to the actual login user, but, having launched X beforehand as "root", it could have been re-created owned by root:root.

In order to check the situation:

Could you please open a text console ([Ctrl][Alt][Fx] where x > 2), log in with your normal user name and check this aspect with the following command?

ls -l /home/user/.Xauthority`

where user is your (short) login name.

Normally, instead of root:root the ownership is user:group


In order to fix the graphical login problem:

If I'm correct, the problem can be solved by changing the ownership in this way:

sudo chown user:group /home/user/.Xauthority

where, if unsure, the actual values of user and group are to be checked against other files in your home directory

The exact thing has occoured to me also in environments others than yours

  • Very good explanation. I will upvote this when I get 15 points in reputation! However, Sourcejedi was first and I also used his info to fix my problem so I'm compelled to accept his answer. – Rimfire Jun 7 '16 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.