-1

Bash script

#!/bin/sh
xflux -l 55 -g 37

How autoboot it precisely in debian 8? I.e via "Startap Application" command

gnome-terminal -e /path_to_script/script.sh

Doesn't work

closed as unclear what you're asking by dr01, Rui F Ribeiro, Bananguin, Flup, don_crissti Jun 7 '16 at 16:23

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I think it would help to know what desktop environment you're using - it looks like the default for Debian 8 is Gnome 3.14 and if you're using that then you probably want to make the script executable (chmod +x ~/scripts/start_xflux) and then run that from the Gnome autostart dialogue – Jonathan Austin Jun 7 '16 at 13:33
  • I use cinnamon. – delkov Jun 8 '16 at 5:03
1

I think this covers your use case:

Start Script when Gnome Starts Up

and involves creating a .desktop file and dropping it in ~/.config/autostart:

EG

[Desktop Entry]
Name=MyScript
GenericName=A descriptive name
Comment=Some description about your script
Exec=/path/to/my/script.sh
Terminal=false
Type=Application
X-GNOME-Autostart-enabled=true

Not the answer you're looking for? Browse other questions tagged or ask your own question.