3

I've currently installed Windows 7 and Ubuntu via dualboot. To avoid switching the OS by rebooting, i want to be able to start my Windows 7 via a virtual machine.

It is important to be able to boot Windows directly. Windows itself is configured via domain by my employer. However these restrictions (no port opening, no software installations, internet over proxy etc) make it far do difficult for my job as developer. (to avoid unnecessary discussions: there is no way to get any other configuration by the company. Tried everything, its simply a NO)

Now i installed Ubuntu which allows me to actually use my IDE, debug my code, compile my stuff, whatever.. Simply put: it allows me to work.

There is only a single problem: I cannot access my E-Mails, Calendar and Phone-System. These systems are configured to run only over a proxy which whitelists you as long as your Windows Domain Login is signed in.

So the general idea is to load up the Windows inside a virtual machine, to be able to use Outlook and the other applications. I do not need that much performance on the VM anyway.

I tried working with Virtualbox, but due to the fact the BIOS is locked, VT features are disabled in the bios, and the Windows install is a 64bit Installation, i have decided to use qemu.

I came across this article: http://fds-team.de/cms/articles/2013-12/use-a-real-windows-7-partition-in-virtualbox-kvm-vmware-player-u.html which i am trying to follow currently.

I've read the whole article, but i get stuck pretty quickly. When creating the linear raid, i get /dev/md0 which is exactly 43 sectors smaller than it should be. Now i am afraid of progressing further, as destroying the Windows installation has to be avoided at all cost.

This is my disk partition table:

Disk /dev/sda: 111,8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x8c663b07

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1  *         2048   1023999   1021952  499M  7 HPFS/NTFS/exFAT
/dev/sda2         1024000 118211499 117187500 55,9G  7 HPFS/NTFS/exFAT
/dev/sda3       118212606 234440703 116228098 55,4G  5 Extended
/dev/sda5       118212608 217847807  99635200 47,5G 83 Linux
/dev/sda6       217849856 234440703  16590848  7,9G 82 Linux swap / Solaris

And this is the md0 device:

Disk /dev/md0: 56,4 GiB, 60524265472 bytes, 118211456 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xd765df67

What is causing this mismatch? Is there any way i can fix this, or is there any other approach to boot my local installed Windows 7 into Ubuntu? Is there a risk my Windows partition gets destroyed if i proceed to create the partition table on the md0 device?

Any help would be appreciated

  • 2
    Strange situation. Looks like your employer enforces you to mine coal with your hands literally at the beginning of the XXI! As you already made your notebook dual boot, then you have an option to connect external HDD and make a backup of your NTFS partitions with ntfsclone, part of ntfsprogs package. – Serge Jun 6 '16 at 13:37
0

If you could enable VT in your BIOS, it would be an easy task. Maybe your employee could unlock this feature for you?

There is one more thing you may not be aware of: Windows looses its activation if running on another computer. A virtual machine would be very different from your real hardware. This can be circumvented in Virtualbox with some adjustments. I wrote a german Howto about this: https://wiki.ubuntuusers.de/Dualboot-Windows_virtualisieren/

I know little about qemu and about your missing sectors. But you could copy your windows partition as a disk image and run qemu with this image instead of the real partition. I assume your mails and calender are not saved locally, so you would not miss them when booting the real partition.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.