For some reason after reinstalling Debian 8 (LVM encrypted) I need to sudo for any writing command in certain directories of /home/manuel/ directory (not even all of them!).

I tried chmod a=awx [-R] to allow write access to my user (which belongs to the sudoeur group) but nothing changed.

How do I allow any directory under /home/username to be directly readable/writable/executable when my user (username) is signed in?


ls -l /home/manuel/ returns


drwxr-xr-x 4 root root 4096 Jun 6 12:09 subdir # this is the directory I want to give my user full rwx access


  • /home/ is a place where all users home folders is put. My direct path to my home folder would be /home/roxto/ while yours should be /home/jeff/ et.c. – roxto Jun 6 '16 at 10:18
  • of course I meant /home/username. I'll fix the answer's body – dragonmnl Jun 6 '16 at 10:20
  • can you please do ls -l /home/manuel/ – roxto Jun 6 '16 at 10:29
  • quesions's body* – dragonmnl Jun 6 '16 at 10:29
  • @roxto I updated my question – dragonmnl Jun 6 '16 at 10:52


chown manuel:manuel /home/manuel/subdir/ 

above command will give your account ownership over the folder subdir, if there's more directories owned by root under subdir (you can check with ls -Rl /home/manuel/subdir/) you could add the recursive option -R to the earlier chown command like this chown -R manuel:manuel /home/manuel/subdir/. That'll make all folders under subdir owned by manuel.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.