1

I've done everything I thought was needed, but can't get this library to be installed properly.

ldconfig -p | grep libcppunit

keeps returning the empty string.

To install it, I've run (do not have root access):

./configure --prefix=some/home/folder

make

make install

even with LDFLAGS and CFLAGS included and all files are put in the installation folder correctly. Also, environment variables are set to this installation folder (LD_LIBRARY_PATH, LIBRARY_PATH to lib; CPATH to include; path to bin) but it won't work. When trying to access this library from compiling another program, it returns the error as noted in the title. On the other hand, I did exactly the same thing for another library (popt), which runs fine and is recognized by ldconfig -p | grep libpopt!!

Does anybody know what I'm doing wrong or what I can try in order to solve it?

When running

ld -lcppunit -ldl -L/some/home/folder

it tells me that it could find the library files, but also returns no symbol _start can be found and is not setting a starting point.

Running RedHat Enterprise Linux 6.5

0

Your question doesn't specify if you are exporting the variables or not, so I'm operating on the assumption that you haven't exported them.

Set your variables as you normally do, but before running the command you need to run, export each one.

export LD_LIBRARY_PATH
export CFLAGS

In this way, you make the variable available to everything you run in that particular session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.