1

So I've started going through some penetration testing books and tried to set up Kali on the raspberry pi 3b. I'm having some trouble, though, namely that Kali could detect all the WiFi networks around me right after I put the imaged sd card in the Pi, but cannot connect to my network, no matter if try via the GUI or via command line ( I followed these instructions for the command line, with wpa_supplicant etc).

The password is definitely correct, I quadruple-checked.

I also tried using an external USB-Wifi-Adapter, but without success.

(I might try checking if I can connect to the WiFi if I put Raspbian on the Pi next)

Now, am I correct in assuming that since it detects the networks, this can't really be a driver issue? I also used Offensive Security's image specifically designed for the Pi from here . Can anyone help?

output of iw wlan0 scan:

BSS *BSS*(on wlan0)
TSF: 0 usec (0d, 00:00:00)
freq: 2462
beacon interval: 100 TUs
capability: ESS Privacy ShortPreamble ShortSlotTime (0x0431)
signal: -59.00 dBm
last seen: 0 ms ago
SSID: *MY_SSID*
Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0* 9.0 12.0* 18.0 
DS Parameter set: channel 11
Country: DE Environment: Indoor/Outdoor
    Channels [1 - 13] @ 20 dBm
ERP: <no flags>
Extended supported rates: 24.0* 36.0 48.0 54.0 
HT capabilities:
    Capabilities: 0x1ad
        RX LDPC
        HT20
        SM Power Save disabled
        RX HT20 SGI
        TX STBC
        RX STBC 1-stream
        Max AMSDU length: 3839 bytes
        No DSSS/CCK HT40
    Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
    Minimum RX AMPDU time spacing: 8 usec (0x06)
    HT TX/RX MCS rate indexes supported: 0-23
HT operation:
     * primary channel: 11
     * secondary channel offset: no secondary
     * STA channel width: 20 MHz
     * RIFS: 0
     * HT protection: nonmember
     * non-GF present: 1
     * OBSS non-GF present: 0
     * dual beacon: 0
     * dual CTS protection: 0
     * STBC beacon: 0
     * L-SIG TXOP Prot: 0
     * PCO active: 0
     * PCO phase: 0
Extended capabilities: 6
WMM:     * Parameter version 1
     * BE: CW 15-1023, AIFSN 3
     * BK: CW 15-1023, AIFSN 7
     * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
     * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
RSN:     * Version: 1
     * Group cipher: TKIP
     * Pairwise ciphers: CCMP
     * Authentication suites: PSK
     * Capabilities: 1-PTKSA-RC 1-GTKSA-RC (0x0000)
WPA:     * Version: 1
     * Group cipher: TKIP
     * Pairwise ciphers: TKIP
     * Authentication suites: PSK
WPS:     * Version: 1.0
     * Wi-Fi Protected Setup State: 2 (Configured)
     * Response Type: 3 (AP)
     * UUID: 16e0d719-674e-1ef0-7581-c80e14cc952b
     * Manufacturer: AVM
     * Model: FBox
     * Model Number: *MODEL_NUMBER*
     * Serial Number: *SERIAL_NUMBER*
     * Primary Device Type: 6-0050f204-1
     * Device name: *DEVICE_NAME*
     * Config methods: Display, PBC, Keypad
     * RF Bands: 0x1
     * Unknown TLV (0x1049, 6 bytes): 00 37 2a 00 01 20
1

Had the same issue, just open the terminal and type:

ifconfig wlan0 up

Change the "wlan0" with the interface you want to use. Type ifconfig to see all interfaces.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.