1

I am trying to install NVIDIA driver for my geforce 830m. My computer is a Dell Vostro 5480 with Intel HD Graphics 4400, and I can't disable the Intel graphs on BIOS so I presume that I need to use BUMBLEBEE library.

My current Kernel version is 3.16.0-4-amd64 over a Debian Linux 8 O.S

My /etc/apt/sources.list:

    deb http://ftp.br.debian.org/debian jessie main contrib non-free
    deb-src http://ftp.br.debian.org/debian jessie main contrib non-free

I have installed Bumblebee so I can run sucessfully optirun, but primusrun simple doesn't work:

    $ primusrun glxgears 
    Falha de segmentação (segmentation fault)

Edit: Ok so I follow the debian jessie-backport tutorial about installing bumblebee and it didn't work. Then I made some changes that I will share it here:

  1. Add this to the end of the file /etc/bumblebee/xorg.conf.nvidia

    Section "Screen"
     Identifier "Default Screen"
     Device "DiscreteNvidia"
    EndSection
    
  2. On file /etc/bumblebee/bumblebee.conf we made two changes. First, in section [blumblebeed] let Driver be equal to blank

    Driver = 
    

    Second, in section [driver-nvidia] ensure that

    KernelDriver=nvidia-current
    
  3. You need install or reinstall (don't ask me why) the following libs:

    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx
    
  4. Make sure that you had downgraded the "intel-debian-issue" libdrm from 2.4.58 to 2.4.56. libs

  5. Test the software

    sudo optirun -vv glxheads
    
    sudo primusrun glxheads
    
  6. Verify if you had changed line on the file /etc/default/grub for:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1"
    
  7. On Steam, just click right button on a game then properties then SET LAUNCH OPTIONS and choose for

    optirun %COMMAND%
    
    primusrun %COMMAND%
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.