3

I am attempting to build Swift using the new port on FreeBSD 10.2, however, make throws the following error :

llvm38-3.8.0_3 is marked as broken: LLDB does not build with Python 3.

What do I need to do to resolve this?

1

If you can live without lldb you can run

cd /usr/ports/llvm38
make config

and remove the lldb flag.

LLDB Install lldb, the LLVM debugger (ignored on 9.x)

I don't know if swift needs lldb to work.

But as long as the port is broken you need to deactivate it, until it will be fixed, which will happen at some point.

  • As far as I know, you need lldb for the REPL support. on macOS, lldb --repl invokes swift repl. – fnisi Feb 3 '18 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.