2

I have two Ethernet-wired connected devices. I gave to both of them address from same sub-network. As result I can see second device in arp-table of the first.

$ arp -a
? (128.247.77.90) at 10:60:4b:4b:29:50 [ether] on eth0

But ping always fails.

$ ping 128.247.77.90
PING 128.247.77.90 (128.247.77.90) 56(84) bytes of data.
From 128.247.77.158 icmp_seq=9 Destination Host Unreachable

First device is a laptop. It's a host. Second is a tablet under u-boot. I have to get a file from a host via TFTP. This protocol fails too because of ICMP. Here are all packets that Wireshark caught.

enter image description here

What is the reason of this problem?

  • It seems a configuration error. The .158 ask who is behind the .90 to give it a reply, but the .90 answers only after 100 seconds – Giacomo Catenazzi Jun 3 '16 at 13:34
  • Can you wireshark what happens when you run tftp on U-Boot? The network is not active all of the time in U-Boot so pinging from the host will not work in general. – Tom Rini Jun 3 '16 at 13:36
  • What kind of cable do you have connecting them? Straight-thru or crossover? Sometimes your situation requires a crossover. Also, use mii-tool or ethtool on the interfaces (i.e. ethtool eth0) to see if there's a link-level connection at all. IP won't work until ethernet does. – Bruce Ediger Jun 3 '16 at 13:39
  • @TomRini, in the picture you can find lines number 20, 22, 32 and 34. That are attempts to use tftpboot from device under u-boot. – Dropper Jun 3 '16 at 13:50
  • @BruceEdiger, ethtoo eth0 gave me Link detected: yes – Dropper Jun 3 '16 at 13:52
2

The problem was with configuration of tftpd-hpa server on host. According to guide the file /etc/default/tftpd-hpa must be something like:

TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/home/bogdan_liulko/tftp"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="--secure --create"
RUN_DAEMON="yes"

My problem was that my file didn't contain --create parameter in TFT_OPTIONS. And right after all steps from guide were done everything started work properly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.