1

I have a VPS server at DigitalOcean with a domain. There is a postfix server and a mailman (mailing list server) running on it. Also my personnal email address is @hotmail.fr (nobody's perfect) but I created it a long time ago and for various reasons I do not want to change my provider.

I want to use my postfix server as a smtp server from an other host. Before to search how to expose a postfix server that way I wanted to test whether I could mail directly from command line. And this is the weirdness: when I mail myself from command line using my x@hotmail.fr address I don't receive the mail. So I decided to try to send a mail the same way but to a friend using a y@gmail.com address. And he did receive the mail.

I concluded that Microsoft has blocked my domain. But...

I have created about a month ago a mailing list to which I subscribed. Some friends have subscribed to and they have @gmail.com addresses. When somebody send message to this mailing list, I do receive the mail sent by my mailman server. When I created that list, I remember that I've checked sending mail to myself at x@htomail.fr using command line. That worked. If I send a mail to mail-tester.com, it receives it (and gives me a 10/10 score...). I also tried to create a new mailing list and I don't receive anything from it.

So, I don't know what to do.

Could it be a config issue since it works with one of my mailing list but not any new one (nor directly using cli) ? Or is Microsoft able to block one all email addresses from my domain but one ?
What can I do to get it working ?

I forgot to say that I have also checked my spam folder on my mailbox.
And I use opendkim to sign my messages.

  • Usually if big ones ban your emails this means that your IP is not so very clean from a spam lists viewpoint; it was "spammed" long time ago or just has such a bad reputation because of being inside other, bigger block of ISP ips which is banned. Try checking your VPS IP on mail spam list checkers, like mxtoolbox.com. – user140866 Jun 3 '16 at 16:04
  • Hi @siblynx, thanks for your response. I made the test. And it said me that my reverse DNS is not a valid hostname. So I have to fix it. But I don't really know how to do . – MichelPeseur Jun 3 '16 at 20:11
  • Also why does it work with one of my mailing lists ? – MichelPeseur Jun 3 '16 at 20:31
  • If you have no reverse DNS set up (i.e. PTR record) then you should call your VPS provider support and request one for your VPS ip, pointing to your domain. They should give you one I believe. This is the reason I think why you are still blocked from some big email servers because it's a basic requirement. – user140866 Jun 4 '16 at 3:30
  • And why it works for mailing lists - well, maybe some headers were omitted when you did test send and it worked, or maybe first time does not count. Still, just receive PTR record and problems should go away if you have no other issues. – user140866 Jun 4 '16 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.