0

When I create vnc for my linux box, its showing desktop when I login. I want only xterm windows. I see xterm under /bin/xterm. Please help.

  • could you clarify your question please. It is not clear what you want to achieve – Serge Jun 3 '16 at 6:52
  • I need to be only seeing xterm window. I see shared desktop from utlra vnc. After I create a client, and login from client I see server desktop. I want to see only xterm window, which is like terminal. – Srikanth Yadake Jun 3 '16 at 7:03
  • How did you start your xvnc server? – Serge Jun 3 '16 at 7:10
  • >vncserver, one command – Srikanth Yadake Jun 3 '16 at 7:11
  • Or how to attach xterm to xvnc, I need to switch off desktop. I need only xterm – Srikanth Yadake Jun 3 '16 at 7:12
1

We need to edit file $HOME/.vnc/xstartup with the contents below:

#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &
/opt/fvwm/bin/fvwm2 &

This will turn off desktop and show only xterm windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.