1

How can I mount my Samba HD from my stock Asus n66u router to Linux Mint laptop over the air? I’ve tried tutorials, but they are either very confusing (since I don’t use Linux too often) or using a command I don’t have in Linux (e.g., findsmb). SMBCLIENT and SYSTEM-CONFIG-SAMBA have been installed from the software manager. I’ve set up Samba on my Windows machine and Android phones, but would like it on my Linux machine as well. Having a link to the shared folders on my desktop would be great; I would hate to have to use the terminal every time to access a file.

4

If you have a graphical desktop environment (like Gnome) you can use Nautilus (the file explorer) and use the address bar. You might need to use the 'toggle location entry' button or menu view option to make the address bar visible.

Once you have the address bar you can enter the URI to the samba share using:

smb://host-or-ipaddress/sharename

When you entered the desired share, you can create a bookmark using menu Bookmarks/Add Bookmark (Ctrl+D). This will add a link in the left side bar for quick access.

Using a terminal, you can mount (as root or sudo) using:

mount -t cifs //hostname-or-ipaddress/sharename -o username='username',domain='domainname-or-workgroup' /mnt/mysamba

Where /mnt/mysamba need to be an existing directory.

Also note that you need to have the package cifs-utils installed.

|improve this answer|||||
  • Ok so I entered the share address in the gui window, it pops up asking to connect as anonymous or registered user, enter all my credentials correctly and it comes back asking for the same information again. Any ideas? – axxic3 Jun 4 '16 at 3:04
  • Can you setup the mount using a terminal window? – Lambert Jun 7 '16 at 9:41
  • I made the directory /mnt/mysmba (misspelled it but changed the command accordingly) and entered in terminal: sudo mount -t cifs //192.168.1.1 -o username=user,domain=workgroup /mnt/mysmba and i get back: Invalid argument Refer to the mount.cifs(8) manual page – axxic3 Jun 7 '16 at 23:15
  • I was entering the address wrong, along with the workgroup being case-sensitive. using the ip address of the router instead of its "samba" name worked. I also needed to point to a folder within the drive since I guess the permissions are structured more complex than I had remembered and wouldn't allow access to the whole drive. Thank you thank you thank you! Huge headache gone. – axxic3 Jun 7 '16 at 23:36
0

You can also enter smb://host-or-ipaddress/sharename to location bar in your Files window and than enter username, domain and password in the window that pops up.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.