2

Recently I installed debian on a separate drive on my desktop. My keyboard worked in the grub menu but not in the installation menu (I figured this was a fluke and pulled out an old ps/2 keyboard which helped me finish my installation). Then I booted into the drive and my keyboard worked in grub. I'm then presented with a password prompt to decrypt but the lights on my keyboard flash and it doesn't work. I login using my old keyboard and my regular keyboard still doesn't work inside the OS.

What I tried:

Enabling Intel VT in BIOS,

Enabling legacy support in BIOS,

appending 'noapic' and 'nolapic' on 'linux ...' in grub - side note, I restarted to see if the changes stuck and they weren't there.

Please help, I need this keyboard to work as it is an adaptive keyboard

  • What is the brand and model of the keyboard? – Peschke Jun 2 '16 at 22:28
  • That would be odd but its Aivia k8100. Let me clarify, it's a regular keyboard with a keyguard over it that makes it adaptive – Peter Krasinski Jun 2 '16 at 22:31
  • What does dmesg says when you plug/unplug the keyboard? – grochmal Jun 2 '16 at 22:40
  • This is weird but the media control buttons work but regular input doesn't – Peter Krasinski Jun 2 '16 at 23:16
  • checking /var/log/dmesg after plugging/unplugging shows nothing. running 'dmesg | grep -i usb > unplugged.txt' plugging it in and running 'dmesg | grep -i usb > plugged.txt' gives [pastebin.com/tUZecKLZ] – Peter Krasinski Jun 3 '16 at 0:57
0

You need to switch from gaming mode to the normal mode , connect your keyboard and press Ctrl + Shift + n , or shift+Ctrl+Alt+n

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.