There are free vst and aax (Pro Tools) plugins installed as part of 360 Spatial Workstation. These are greyed-out (as if requiring a license), or invisible (VSTs e.g. in Ableton Live). If you login as an administrator they appear with no issues.

This is not acceptable, because in a large music studio, we naturally do not let guests, artists, students, and so on, install programs or other admin tasks.

The program should have all the permissions necessary, to change almost any system component, and not require system-level restrictions in the actual plugins.

So the other parts of "360 Spatial Workstation" also known as FB360 now in collaboration with a team at Facebook work fine, just not the plugins in DAW programs.

It seems if you are not the administrator while wanting to use any of the Digital Audio Workstation compents of this program, the DAW cannot find the plug-ins on the system, and refues to acknowledge the "free" license (for example the Pro Tools .aax plugins).

The systems are OSX 10.11, facing the same issue with all non-admin users whether local or ldap users.

I am used to solving minor problems in similar programs with relatively-simple ****Bash* scripts or by tweaking unix-style config files or plists in ~/Library/Application Support/$Application as well as ~/Library/Preferences and the local, system-wide files***, similarly, but there are no files here to modify.

I've tried to post questions at The developers' help desk but can't seem to login or create an account.

I have also tried opening the permissions wide to 0777 on all of the components inside the Applications package, as well as the individual plugins. I also wanted to force the components to run suid as an administrator, but so far this has not worked, but this is the basis of tricks for unix & linux (on ***osx*, here)** that I am hoping to most get some tips on. It seems like the way Pro Tools plug-ins--but also the VST plugins--are implemented, contain within their packages also levels of access restriction, which is not normal for these plug-ins in my experience.

I also tried using the sudo system to allow specific users to access the plugins, and this made no difference.

  • added an update here about seeking help elsewhere, still no solution yet Jun 1, 2016 at 15:08
  • updated again with some things have tried Jun 3, 2016 at 11:38
  • Since there are no answers or comments, I'm updating question to make it more generic or useful to others, also to set up a bounty Jun 28, 2016 at 14:45
  • Have you tried tweaking the Option RootVolumeOnly="True" in the distribution.cfg file, in the package? For example try False or other similar values, and then repackage. I will look into it further... Jul 2, 2016 at 11:32
  • I tried that actually, it seemed to have no effect; also some of the components of the package are binary (a bit unusual for VSTs and such...) so beyond that it's really hard to see what's going on without forensic tools or such that I don't have much experience with. Jul 4, 2016 at 7:54

1 Answer 1


You can't use the plugin portions of this package at this time, as a non-admin user. You and I both know that is a security risk, and others may know it is not necessary, but that is the answer.

I verified that what you mentioned before about sudo was correct, and as well, there were no unix-level tweaks I could work out. I agree it would be cool if in the future people add more to this post in regards to how to general tweak the VST or other plugin formats. A great resource is Steinberg (their developers' site is here), where you can read up on the VST specifciations. You may even be able to modify the 360 plugins with info that is there, and basic Unix/OSX knowledge. Maybe Avid has a similar resource for the AAX format.

I played around with their installer a bit, and read over the support group. Actually it seems to have quickly turned into a general forum about VR, and users-helping-users, not so much of a support group; but in general the VR movement looks awesome, so I have big hopes for the project!

Someone asked about a month ago about non-admin use, and someone gave a non-response of "well you had to be admin to install it, didn't you," so I think the venue is not right for these type of security-centered questions. I had also the same experience as you, with their pre-FB support pages, which seem to be closed now.

I have experience either personally, or as admin for clients, with almost all the leading music hardware, DAWs, and plugins, and none of them, I mean zero--and only one piece of hardware I know of (and that not even certainly)--needs strict admin access to work. A program like Pro Tools has all the rights, all on its own, to tweak the audio and video settings in your system, and does not need its plugins, to run strictly with root privileges.

Spatial workstation should work with every DAW, according to their own site so apparently they've just left out support for non-admin users, which seems a bit awkward to me; To speculate further wouldn't be justified, but the sure answer is it is not yet ready for prime time, and certainly, at least, not purposefully build for educational or group use.

  • Wow, thanks for the links (esp. Re: VST, osx/unix dev); I don't have FB (not a huge fan of the segmented web), but this is really helpful, and for me as well the current answer. Jul 5, 2016 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .