5

I had centOS installed in my system and after installing ubuntu the boot loader (grub2) doesn't display CentOS entry. I tried "sudo update-grub" in Ubuntu terminal but it doesn't show CentOS image. I also installed "grml-rescueboot" as mentioned in the grub2 manual but it also didn't work. How should I add CentOS manually in the grub2 of Ubuntu? I would be grateful if someone tells me how to fix this issue.

2
  • Reinstall grub with sudo grub-install /dev/sda, and follow that with sudo update-grub.
    – malyy
    Commented Jun 1, 2016 at 11:29
  • I tried to do so, but I got the error- "failed to get canonical path of /cow"
    – rmb
    Commented Jun 1, 2016 at 12:44

2 Answers 2

1

Boot repair is your tool unless you installed Ubuntu to the same partition and overwrote CentOS.

2
  • Boot repair worked wonders! Thank you so much for your suggestion :-D
    – rmb
    Commented Jun 1, 2016 at 13:13
  • It saved my life not once ;)
    – Igor Andri
    Commented Jun 1, 2016 at 13:32
0

You need to update grub.cfg , the new entries will be added automatically. From the existing OS (Ubuntu) open the terminal and type the following command:

grub-mkconfig -o /boot/grub/grub.cfg

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .