1

I came to know that I have an AlaDelta theme sitting/hiding somewhere on the system. I tried the following approaches -

$ apt-file search aladelta

with variations of aladelta in some caps, all caps but no avail.

$ aptitude search aladelta 

Also tried various theme packages which I have installed to see if one of them might have this theme but it's a long slog.

[$] dpkg -l | grep -i theme

Any ideas how to figure out where this theme might be holed up ?

~/.themes 

is empty.

[~/.config/gtk-3.0] - [10106]
└─[$] cat settings.ini                                                                                                                
[Settings]
gtk-theme-name=AlaDelta
gtk-icon-theme-name=matefaenzagray
gtk-font-name=Sans 12
gtk-cursor-theme-name=DMZ-Black
gtk-cursor-theme-size=48
gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintmedium
gtk-xft-rgba=none
gtk-application-prefer-dark-theme=1

This has become an issue as the theme is supposed to be a fork of adwaita and is obsolete by many years. I came to know about it as it started giving gtk warnings as just have upgraded to gtk-3.20 .

  • Post the output of ls /usr/share/themes, ls ~/.themes, ls ~/.local/share/themes, and ls ~/.local/themes. – DK Bose Jun 1 '16 at 4:28
  • Link to your related question: unix.stackexchange.com/questions/286558/… – DK Bose Jun 1 '16 at 4:30
  • You should post the content of the gtk warnings. I'm guessing you'll find a path in there and then you can use dpkg -S <somefile> to tell you the package that owns the file. – Peter Jun 1 '16 at 12:22
  • Actually while I can share the content of gtk warnings, I don't think that will help in this case . [$] mate-tweak (mate-tweak:14263): Gtk-WARNING **: Theme parsing error: gtk.css:63:28: The :prelight pseudo-class is deprecated. Use :hover instead. (mate-tweak:14263): Gtk-WARNING **: Theme parsing error: gtk.css:73:35: The :prelight pseudo-class is deprecated. Use :hover instead. – shirish Jun 1 '16 at 14:55
  • 1
    Looks like it's a Mate theme according to git.mate-desktop.org/mate-themes/diff/…. You really need to clean up /usr/share/themes :) GTK-3.20 is well known for breaking older themes! Even the Arch guys are complaining. Unless you find a theme that's expressly written for GTK-3.20, you're going to face issues. If locate or mlocate doesn't find it, why do you think it's still around? – DK Bose Jun 1 '16 at 15:26
1

The AlaDelta theme does not appear to be in any standard Debian package.

If you installed it from a non-standard package, you could find out the package name with:

grep -il aladelta /var/lib/dpkg/info/*.list

Alternatively, if that results in an error message about "argument list too long" or similar:

find /var/lib/dpkg/info -name '*.list' -exec grep -il aladelta {} +

The package name will be the filename without the .list suffix.

If that doesn't find it, it's a local (i.e. non-package) install, perhaps somewhere under /usr/local/. If you have mlocate installed, you can find out where the theme is on disk by running mlocate -i aladelta. You should then be able to delete the theme's files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.