0

after upgrade debian i cannot open or ping any domain even in firefox (but i havnt any problem via proxy).

for example wget:

unable to resolve host address ‘google.com’

but i can work with ip (add in /etc/hosts) or dig any domian

; <<>> DiG 9.10.3-P4-Debian <<>> debian.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35527
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;debian.org.            IN  A

;; ANSWER SECTION:
debian.org.     45  IN  A   149.20.20.22
debian.org.     45  IN  A   5.153.231.4
debian.org.     45  IN  A   140.211.15.34
debian.org.     45  IN  A   130.89.148.14
debian.org.     45  IN  A   128.31.0.62

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jun 01 09:03:52 IRDT 2016
;; MSG SIZE  rcvd: 119

i also can access to ip directly or access to domain with /etc/hosts

my /etc/resolv.conf:

nameserver 127.0.0.1 
nameserver 8.8.8.8

and my /etc/NetworkManager/NetworkManager.conf:

[main]
plugins=ifupdown,keyfile
#dns=dnsmasq
[ifupdown]
managed=false

when i run nmcli dev show | grep IP4.DNS:

IP4.DNS[1]:                             127.0.0.1
IP4.DNS[2]:                             8.8.8.8

apparently every thing is ok but i cannot access to any domain directly.

Any help with this would be best appreciated!

  • What's your /etc/nsswitch.conf look like for the hosts: line? – derobert Jun 1 '16 at 1:28
  • hosts: files mdns4_minimal [NOTFOUND=return] dns – Parazitt Jun 1 '16 at 2:19
  • does getent hosts google.com work? – derobert Jun 1 '16 at 5:30
  • no, not working but when i put in /etc/hosts working – Parazitt Jun 1 '16 at 8:04
  • This is... a head scratcher. Are you using nscd, unscd, or similar? Also, in case it matters, which local DNS cache are you using? – derobert Jun 1 '16 at 9:00
0

Why do you have the line nameserver 127.0.0.1 as the first option? You can put it after primary dns like 8.8.8.8. Again, in your /etc/NetworkManager/NetworkManager.conf, try to set

dns=default
  • dig shows that 127.0.0.1 is working... – derobert Jun 1 '16 at 1:27
  • tanks for replay, but no problem not fixed – Parazitt Jun 1 '16 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.