0

I just started on a fedora build. Just managed to add myself to the sudoers file, so now I am attempting to grab vim. I do a

sudo dnf install vim

and get hit with the following error message.

Error: Failed to synchronize cache for repo 'fedora' from 'https://mirrors.fedoraproject.org/metalink?repo=fedora-23&arch=x86_64': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-23&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]

To me, this looks like a proxy issue. I attempt this

export http_proxy="<my proxy>"

And then retry

sudo dnf install vim

Same response. I know the proxy is correct, as it worked for me on a previous RedHat build, so can someone recomend me the next steps to try here?

2

After some research, I found that I needed to open

/etc/dnf/dnf.conf

and add the line

proxy=http://<my_proxy>:<port>

Simply setting the http_proxy in the bash shell was not enough.

0

I resolved the same problem by adding the proxy entry to /etc/dnf/dnf.conf. However we use the default http port 80 so I set the proxy as follows:

proxy=http://192.168.0.1

This did not work. The proxy setting required the port.

proxy=http://192.168.0.1:80

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.