Brand new F23 install, trying to update the kernel. I did lose power during the first round of dnf update and have to go clear out a bunch of conflicts that dnf kept reporting. It's possible I removed something that's needed, to be totally honest here.

Anyways, I've tried both dnf update and dnf install kernel (after dnf remove kernel). They install the latest kernel to /lib/modules/4.4.9-300.fc23.x86_64/, but no new vmlinuz files end up in /boot, so grub2-mkconfig won't find it and use it.

Any suggestions as to where I could start troubleshooting this?


Ended up updating to the F24 beta, as it's being frozen anyways. This fixed the problem, and I'm now running on the 4.7 kernel.

dnf reinstall kernel-core

vmlinuz file is provided by kernel-core package so you will need to reinstall it

source https://forums.fedoraforum.org/showthread.php?310114-Updating-kernel-vmlinuz-in-boot-not-being-created-by-DNF


I'd try

dnf reinstall kernel

or (better)

dnf reinstall kernel-4.4.9-300

since it's possible that dnf has status saying that the given set of files is complete.

  • Tried both, it's still not putting a vmlinuz/initramfs/config/System.map file in /boot – Big Millz May 31 '16 at 1:37
  • I did just notice that when dnf lists the kernel package, arch, version, etc upon running dnf install kernel...the size is 58k. Normal? – Big Millz May 31 '16 at 1:46
  • That's too small (the kernel is several Mb). Your /boot may be short of disk space. – Thomas Dickey May 31 '16 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.