4

On a computer with the Intel® 7265D wifi device iw reg get produces the following output:

global
country 00: DFS-UNSET
    (2402 - 2472 @ 40), (N/A, 20), (N/A)
    (2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
    (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
    (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, NO-IR
    (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, NO-IR
    (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
    (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
    (57240 - 63720 @ 2160), (N/A, 0), (N/A)


phy#0 (self-managed)
country DE: DFS-UNSET
    (2402 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
    (5170 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, GO-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
    (5250 - 5330 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
    (5490 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
    (5735 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, GO-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
    (5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, GO-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN

According to the output the wifi card seems to manage the regulatory domain itself. The set country DE is correct, but the information on the used frequencies and txpowers do not match the regulations for DE. On a another computer with a Intel® 7260 I get the following output and this is what I expect.

country DE: DFS-ETSI
   (2400 - 2483 @ 40), (N/A, 20), (N/A)
   (5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
   (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
   (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
   (57000 - 66000 @ 2160), (N/A, 40), (N/A)

This is the list I expect from reading the wireless-regdb (see http://git.kernel.org/cgit/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt).

The problematic output for the 7265 was produced on computer running openSUSE Leap 42.1. The crda version is 3.18-5.1 and the version of wireless-regdb is 2015.07.20-1.1. Thus outdated versions cannot be the reason for this problem.

My guess is, that the output of iw reg get is not correct for self-managed devices. This would explain the correct information in case of the 7260 module. According to iw this is not self-managed.

Thank you very much.

P.S.: some information on the 7265D module

[...]loaded firmware version 25.30.13.0 op_mode iwlmvm
[...]Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
2

It is possible to disable the LAR functionality, so it won't appear as a "self-manged" device anymore. Then You can set the regulatory domain with iw reg set. All you need to do is setting the iwlwifi parameter lar_disable=1:

  1. Either manually: modprobe -r iwlwifi && modprobe iwlwifi lar_disable=1

  2. Automatically: echo options iwlwifi lar_disable=1 >> /etc/modprobe.d/iwlwifi.conf

1
  • Thanks for your answer. I do not want to change the regulatory domain. I just did not know how to interpret the output of iw reg get in this case. In my opinion it would be cool if iw would be able to display the regulatory domain which was chosen by the firmware of the wifi card in the case of self-managed devices. – user5415068 Jul 1 '17 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.