-1

I recently installed Tails (Linux Distro) on my USB drive. I did it using an intermediary USB stick and i discovered when i installed the final Tails OS on the second USB drive that the size of the hard drive reduced from 15.1 GB to 2.43 GB.

I rebooted my system to windows and tried formatting the hard drive, the size remained unchanged.

Please what do i do. The flash drive originally had 15.1GB total disk space andd after the tails installation, it now has 2.43GB.

  • This site is to help people using Linux, not those that saw it before and don't have access to it anymore. – Julie Pelletier May 28 '16 at 23:28
  • I use linux, i just run it off my USB and i needed the USB for something else so i copied the OS to my windows OS. @JuliePelletier................ Kindly ask before you assume next time. Thanks – proton May 28 '16 at 23:34
  • It's the same thing. You need help on Windows, not Linux. I was not assuming but merely relying on what you said. – Julie Pelletier May 28 '16 at 23:39
  • But the problem was caused by a Linux OS and even when the USB is inserted in a linux system. The partition is still unallocated. But i get your point. – proton May 28 '16 at 23:41
0

Start by checking the partition information with sfdisk /dev/properDevice -Vl.

If the remaining 13GBs are not shown, then it is due to a hardware or driver problem. In that case, testing it on another recent computer would be a good idea and if it still doesn't work, it's a problem with the USB key, probably faked by the one who sold you the key.

You should always do a full format on any new storage devices unless otherwise noted.

  • Hi, i use a windows OS, i dont currently have access to a linux OS. Is there a windows cmd alternative for sfdisk /dev/properDevice -Vl – proton May 28 '16 at 23:18
  • I used disk management GUI in windows and i discovered that the remain 13GB was there but was unallocated and all other options to either extend the 2.4GB partition or create a new partition with the unallocated partition is greyed out. – proton May 28 '16 at 23:22
0

Let’s remove unallocated space. First of all run Windows command line and type diskpart in the command prompt. Windows will ask you for Administrator permissions to run the tool. Then run list disk command to find your USB flash disk’s number. It should be the same as disk’s number in Computer Management tool. It was 1 in my case. Next you should chose the disk to work with. Type select disk <disk number> command, e.g. select disk 1. The next step is to clean all volumes and partitions on the disk. Use clean command to do that. The last step is to create a primary partition. You can do that using create partition primary command. That’s all. You should be able to format your flash disk now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.