21

I have Russian and US English locales. When I'm typing a text in English, it gets underlined until I press Space or some other special keys. When it's underlined, it's kind of invisible to the application where I'm typing it in. For example, in Sublime Text, it isn't even displayed until I press Space. In a browser it won't suggest me a URL until I press Space. It kind of gets buffered — saved in a temporary buffer and then released. And other bizarre stuff like this.

This doesn't happen always, sometimes, around 10% of the time, it works properly, I don't know what it depends on. And it doesn't happen, as far as I can remember, with Russian at all.

It's Arch, XFCE. I've done a bit of a search and haven't found anything anything related to this behaviour.

9
  • I would talk with the Sublime or XFCE guys/foruns to find where to file a bug, and disable the dictionary/autocorrect for a while. Maybe it is a know bug, and there is already a workaround. May 28, 2016 at 5:07
  • Sounds like a bug or misconfiguration in your input method. Check your input method settings. May 28, 2016 at 21:44
  • @Gilles, check what ?
    – Oskar K.
    May 29, 2016 at 15:00
  • 1
    @grochmal, this happens in chrome also.
    – Oskar K.
    May 30, 2016 at 2:13
  • 1
    @Oskar : He means that you have an input method (e.g. English-Us, Anty-Japanese, etc); you configure your available methods with uim-pref-gtk. It looks like you may have a non-English input method selected. Sep 22, 2016 at 21:35

1 Answer 1

27

I also had this same issue (Arch XFCE). Basically what happens is it switches input methods whenever you press Shift+Space, which frequently accidentally happens when typing. To fix this, you have to change or remove this hotkey:

In a terminal window, type uim-pref-gtk, which is the settings for the UIM input method. Go to the Global key bindings 1 section. Then, change the values for [Global] on and [Global] off by clicking edit on them both, and either changing or removing <Shift>space.

4
  • 4
    I wish I could upvote you 10x. This is exactly what was happening with my system as well. Thanks @AHE!
    – Gui Ambros
    Jun 13, 2018 at 3:00
  • 3
    Seconding @GuiAmbros, this is exactly what I needed! Thanks! Why was that so hard to find? I couldn't find it anywhere else... Jan 31, 2019 at 5:43
  • 2
    Thank god I found this - worked for me! This really should probably not be turned on by default. Who knows how many people and hours are being spent on this nonsense.
    – Adam D.
    Sep 20, 2019 at 15:09
  • 1
    Thank you so much. I originally thought this was a change to chrome and was furious. As I started to begin using other graphical application I realized the issue was not isolated to chrome. Never had issues in my terminal which I thought was strange.
    – raman
    Feb 24, 2020 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.