4

A partition of my internal hard drive (not the root partition) I want to mount automatically on boot. I've been using /etc/fstab to mount my external backup drive automatically read-only, so this is the first drive I've tried to mount read-write with fstab. Here's the relevant line:

/dev/sda3   /media/^_^    vfat    rw,sync,user    0   0

Yes, my drive is a silly face. The ^ hasn't caused me any problems before, but maybe it's interfering with something here? Though I doubt it — the drive mounts fine except that it is read-only.

Any reason why this would happen? I've tried restarting multiple times.

  • What's the output of mount -l? Have you tried testing using the options auto,user,uid=your_uid_here,umask=077,rw? – user13742 Jan 7 '12 at 15:22
  • Ah it seems that for some strange reason, it's defaulting to noexec. I'll try restarting with exec explicitly mentioned. – delwin Jan 7 '12 at 15:30
  • 1
    Is there anything in dmesg about the partition? You might also want to look at fdisk -l /dev/sda3 to see if that reveals anything. – Kevin M Jan 7 '12 at 17:47
  • 1
    What is your filesystem? Do you get any warnings or other messages when you manually remount it (e.g. by mount -a)? Note that mounting an inconsistent FAT fs mounts it read-only (see mount manpage). – Adam Zalcman Jan 7 '12 at 20:45
  • 1
    By looking into the output of dmesg and seeing if there's any message from the vfat driver saying the partition has issues and will be mounted read-only. You can also run fsck. – njsg Mar 5 '12 at 19:17
3

Try to use UUID instead of using device name. Because the name of this device (/dev/sda3) depends on the order in which it was detected while booting, and this order can change. Type this command "blkid" without quote, the shell will display all the devices with UUID. Refer below:

[admin@localhost ~]$ blkid
/dev/sda2: UUID="2fc45c8c-7420-48af-8ad5-06cfeda8633b" TYPE="ext4" 
/dev/sda1: UUID="9a070d16-c6be-40a2-8f38-2e52b8010ef2" TYPE="ext4" 
/dev/sda3: UUID="212c65ba-f4bf-4840-8bcc-bb83c5fe63e6" TYPE="swap" 
/dev/sdb1: LABEL="USBtest" UUID="5f42b5d0-375d-4802-8c58-bd6c9c62481b" TYPE="ext4" 
[admin@localhost ~]$ 

Above is an example. Copy your device UUID, then replace with /dev/sda3. Then reboot your server. Hope this can solve your problem. Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.