0

I encountered a very weird issue for git.

I have three repo.s in github, say repo1, repo2 and repo3.

On machine 1, I used to be able to clone and pull all three repos. However, suddenly I couldn't pull or clone repo1 or repo2, but I can still pull repo3 on machine 1.

The error message I receive is git pull origin:

error: The requested URL returned error: 403 while accessing https://github.com/MyGitAcount/scripts/info/refs
fatal: HTTP request failed

I did check the error message help for github. I double-checked that the network on machine1 has no problem.

Is there anyway I can fix this issue on machine1?

BTW, I can clone all three github repos on machine 2 without any problem. So I think there may be something wrong with the configuration on machine1?

[Answer] I didn't change anything and the problem is solved after two days later when I tried it again.

I guess it is either because github has some issues at that time or because my network is not stable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.