I'm frustrated that this was removed/altered in gnome-shell3. There are certain key bindings for resizing and moving windows like alt+right click etc, that I'd like back. I've tried to use the system settings but to no avail. Has anyone else worked with this and got it to work?

6 Answers 6


In more recent gnome versions (e.g., gnome-shell), you need to use this instead:

gsettings set org.gnome.desktop.wm.preferences resize-with-right-button true

Gnome defaults to using the Super ("Windows") key for window actions, so the above alone will enable moving (super-leftdrag) and resizing (super-rightdrag). To use the Alt key instead of the Super key do:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Alt>'

(note that using the Alt key for window operations will interfere with some apps, like Inkscape, that use alt-click and alt-drag for app related actions)

  • 1
    You could also change this same setting with a GUI, via dconf-editor.
    – Victor
    Jan 27, 2014 at 18:35
  • 1
    If you want to use alt+right click, you might also have to change mouse-button-modifier to <Alt>.
    – gogators
    Jul 25, 2014 at 15:12
  • 2
    These gsettings options still work on Ubuntu 18.04. Aug 17, 2018 at 23:10
  • Would like to add that they work in Ubuntu 18.10 also, and not only was this the original answer that helped me find it years ago when it changed, but after the new tweak tool in 18.10 not installing because of mirror problems (and other items), I was about to go mad. Thanks again. Nov 3, 2018 at 13:31
  • 2
    This setting is now exposed in the GNOME Tweaks application under the "Windows" category. Jan 17, 2019 at 23:52

If you install GNOME Tweaks, there's an option to "Resize with secondary click". Checking it will enable Super+RMB to resize windows.

  • 2
    This is the better "single user" preference. Thanks!
    – Rich
    Feb 5, 2019 at 19:38

Additionally to using gsettings and instead of using the deprecated gconf-editor, you can install the newer dconf-editor and find and change relevant keys there. Searching "resize with" will find its key regardless of used WM.


You can use gconf-editor for this. Enable this setting:

  • Unfortunately that doesn't work in later versions of GNOME. The gconf settings are simply not used, it seems.
    – Victor
    Jan 27, 2014 at 18:35

In Cinnamon (rather than Gnome3) the corresponding setting is:

gsettings set org.cinnamon.desktop.wm.preferences resize-with-right-button true

Or find the corresponding path in dconf-editor.

Also see mouse-button-modifier under the same path if you'd rather use the Super key instead of the Alt key for move/resize behaviour (useful for conflicts with other apps such as blender).

  • Your command worked flawlessly, thanks - but I didn't find anything like that path in gconf-editor. Where do those "org.cinnamon.."-like paths reside? (I am running on Linux Mint right now).
    – stolsvik
    Jun 29, 2014 at 21:59
  • dconf, not gconf.
    – RobinJ
    Jun 16, 2015 at 8:55

Just adding that for Deepin linux, the settings are wrapped in com.deepin.wrap.gnome, so I used

gsettings set com.deepin.wrap.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'
gsettings set com.deepin.wrap.gnome.desktop.wm.preferences resize-with-right-button true

instead. Works flawlessly and what a timesaving feature (no more trying to grab the titlebar or tiny window borders)!

Note that since I do use Inkscape sometimes, I prefer the <Super> key. I had to set it explicitely in Deepin..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .