4

I ran hp-setup from the hplip package to install an HP Officejet 6700 connected to the network. The setup program crashed on the first attempt, and succeeded the second time.

The issue I'm having is actually with Firefox's print dialog (possibly other GTK applications as well, still need to test them). There is an additional printer visible named only "printer", and its status is "Rejecting Jobs" until I select it, at which point it changes to "Getting printer information..." indefinitely. Chromium's print dialog only showed the successfully installed printer.

This other printer is not visible through the CUPS HTTP interface, nor through the "lp" commands I found that listed printers.

Is there a way to remove this printer from appearing in Firefox?

1

The solution that worked for me is to edit /etc/avahi/avahi-daemon.conf, setting "enable-dbus=no". I don't know what other side effects this has as of yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.