0

from some reason the script UPMnT.sh not start at boot

I cheeked everything:

chkconfig is ok links are ok

but I worry about maybe there are dependencies between other script to this script

can some one explain how my script under /etc/init.d have dependencies with other script under /etc/inid.d and this is the reason that UPMnT.sh not start at boot

second:

How to understand the line - chkconfig: 345 98 2

what this line mean and how the numbers are dependent with other services?

 # more /etc/init.d/UPMnT.sh
 #!/bin/sh
 #
 # UPMnT   Startup/Shutdown Service Manager shell script
 #
 # chkconfig: 345 98 2




 chkconfig --list | grep -i UPMnT
 UPMnT       0:off    1:off    2:on    3:on    4:on    5:on    6:off
  • The chkconfig line means run at run levels 3, 4, and 5. Start at priority 98 (near last) and start at priority 2 (near the start). – Lee-Man May 23 '16 at 17:44
  • Can you run your script manually, i.e. what does /etc/init.d/UPMnT.sh do? – Lee-Man May 23 '16 at 17:45
  • Lastly, did you run chkconfig UPMnT.sh to enable your service? – Lee-Man May 23 '16 at 17:46
  • when I run the script manual , then its ok – yael May 23 '16 at 17:48
  • yes I run chkconfig on this service and service is enable – yael May 23 '16 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.