2

Problem description

I recently updated my two monitor system from Lubuntu 14.04 to Lubuntu 15.10. I set everything on the new system exactly as on the old one before and I figured out a strange behavior on my desktop:

The primary monitor 1, the start menu position and the position where the desktop icons are located somehow were messed up. Additionally I could not set desktop wallpaper for both monitors.

On the screenshot below you could see the situation. enter image description here

Not only the position of the start menu and icons were messed up, but additionally I couldn't set two different wallpaper, since the Desktop Preferences dialog only changed the wallpaper on monitor 1, but the image scaling took the whole Xserver screen as argument (3840x1200).

There were two different dialogs popping up when using the right mouse click on the desktop. On monitor 2 the openbox popup, on monitor 1 the LXDE popup with limited options.

No matter what I select, only the wallpaper for monitor 1 could be changed. My system setup is:

Operating System: Lubuntu 15.10
Graphics Adapter: Nvidia GeForce GTX 750
Driver:                    Nvidia 352.63
Monitor 1:               HP LP2475w / connected via DVI-I-1 / 1920x1200
Monitor 2:               HP LP2475w / connected via DVI-D-0 / 1920x1200
XServer Screen:    3840x1200
PCManFM:            1.2.3

Anybody having the same problem or a solution how to fix this?

  • Is there a question in there? – roaima May 23 '16 at 12:55
  • Second last paragraph is the question. I also wanted to share my solution – Ede May 23 '16 at 12:56
  • 2
    @ede this site is a Q&A site. You should not put a solution in your post here, but it is perfectly fine to provide the solution as an answer to your own question. If some has a different/better solution they can answer as well. So please split up your post by copying out the answer part to a "Your Answer" section – Anthon May 23 '16 at 13:35
  • @Ede You should also explain what the arrows mean in the picture. – Raphael Ahrens May 23 '16 at 13:50
  • I split up the post as recommended by Anthon, I also added text to the arrows in the image, as mentioned by Raphael Ahrens. – Ede May 24 '16 at 8:35
0

After trying out lots of things and descriptions from the internet, I figured out, that the default file manager PCManFm could be the reason.

Lubuntu 14.04         |    Lubuntu 15.10
PCManFM 1.2.0     |    PCManFM 1.2.3

In LXDE wiki I found out, that there were major changes made to the behavior of PCManFM after version 1.2.0. Therefore I played around a bit and found out the following solution worked for me.

Possible Solution / Workaround:

1. LXSessions Default Applications

In the start menu you choose the „Default applications for LXSession“ from the „Preferences“.

The most top entry sets the default filemanager for the LXSession.

Click on „More“ and change the entry „Manual Setting“ from pcmanfm to pcmanfm --desktop. That forces PCManFM to manage the desktop.

enter image description here

Update the setting by logging out and in again. Just in case you have a keyboard shortcut to open your filemanager, e.g. HOME+e or WINDOWS+e, the system calls the default configuration, which means calling pcmanfm --desktop again. That call actually restarts PCManFM and sets the wallpaper correctly. But when using the keyboard shortcut again, that actually makes the desktop icons disappear and not opening the filemanager!

To fix this, I added the call pcmanfm --desktop to the autostart programs, and manually changed the keyboard shortcut.

2. Autostart

To call the filemanager at least once at system startup, add pcmanfm --desktop manually to the autostart programs in "Default applications for LXSessions" from the "Preferences" menu.

3. Keyboard Shortcut

Edit your keyboard shortcuts using VIM or any other text editor. Edit the file ~/.config/openbox/lubuntu-rc.xml. In the section <keyboard> you can find the keyboard shortcuts for your session. The default looks like this:

<!-- Keybindings for running applications on Home + E -->
<keybind key="W-e">
    <action name="Execute">
    <startupnotify>
            <enabled>true</enabled>
            <name>File manager</name>
    </startupnotify>
    <command>lxsession-default file_manager</command>
    </action>
</keybind>

Change the line <command>lxsession-default file_manager</command> with a direct call to the filemanager pcmanfm on your system, like this:

<!-- Keybindings for running applications on Home + E -->
<keybind key="W-e">
    <action name="Execute">
    <startupnotify>
            <enabled>true</enabled>
            <name>File manager</name>
    </startupnotify>
    <command>pcmanfm</command>
    </action>
</keybind>

After logging out and in again, my systems seems to work now, as I was used to it before, check the picture below.

enter image description here

The icons are on the same monitor as the start menu, two different images were set as desktop wallpaper, when using right mouse click on the desktop, the LXDE Desktop Preferences dialog opens and one can select different images for both monitors.

Hopefully this helps someone, I don't know if it's a bug or a feature of Lubuntu 15.10 / PCManFM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.