1

I have two systems, both running Debian Jessie 8.4, and both have open-vm-tools installed. Files are identical on both sides. However, on one side the vmtoolsd links to an old libicu, althougth the file are identical, which gives me:

vmtoolsd: error while loading shared libraries: libicui18n.so.44: cannot open shared object file: No such file or directory

Here is the ldd output on the failing server:

root@asterisk:/usr/lib/x86_64-linux-gnu#   ldd /usr/bin/vmtoolsd
        linux-vdso.so.1 (0x00007ffec070c000)
        libvmtools.so.0 => /usr/local/lib/libvmtools.so.0 (0x00007fed5ba5e000)
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007fed5b85a000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fed5b607000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007fed5b405000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fed5b0f6000)
        libicui18n.so.52 => /usr/lib/x86_64-linux-gnu/libicui18n.so.52 (0x00007fed5ace4000)
        libicuuc.so.52 => /usr/lib/x86_64-linux-gnu/libicuuc.so.52 (0x00007fed5a966000)
        libicudata.so.52 => /usr/lib/x86_64-linux-gnu/libicudata.so.52 (0x00007fed590f9000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fed58dee000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fed58aed000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fed588d7000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fed586ba000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fed5830f000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fed58107000)
        libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007fed57ed0000)
        libicui18n.so.44 => not found
        libicuuc.so.44 => not found
        libicudata.so.44 => not found
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fed57ccc000)
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007fed57ac4000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fed57856000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fed5bced000)

Only on this system it not just links to libicui18n.so.52 but ALSO links to libicui18n.so.44 ?!?! The other system doesn't have the strange dependency. I already reinstalled libicu52 and open-vm-tools. The file libicui18n.so.4 can not be found anywhere on the server.

What could be the reason for this behavour?

  • 1
    Please update question by appending output of readelf -dW /usr/bin/vmtoolsd – user140866 May 23 '16 at 8:07
2

You're picking up /usr/local/lib/libvmtools.so.0 which is presumably a remnant of a build done on Debian 6 (which had libicu44). If you rename that out of the way, vmtoolsd should find its libraries properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.