0

so this is what I'm trying to use:

rsync -DHilrv --delete --progress /my-local-drive/ /my-network-share/

I've run the command above. After the operation was complete, I ran it again but this time I used --dry-run as an extra parameter, it wants to recopy/redo the transfer of the --same-- files affected on the first run.

The rsync log looks like this on the 1st and 2nd runs.

>f..Tp..... comics/comics1/Issue 0001.cbr
>f..Tp..... comics/comics1/Issue 0002.cbr
>f..Tp..... comics/comics1/Issue 0003.cbr
.
.
. --more files here--
.f.....g... apps/windows/internet/mobaxterm/slash/usr/share/X11/xkb/geometry/pc
.f.....g... apps/windows/internet/mobaxterm/slash/usr/share/X11/xkb/geometry/sanwa

Any ideas on what rsync parameters to use so that I get an empty list on the 2nd run?

Thanks

0

Although you are not using -a nor -g the second rsync -i is wanting to update the group owner of the file. Try adding as 2nd arg: --no-g.

  • -i is suppose to be for information only? Anyway, I tried your suggestion and I removed -i and I got the same results. Also from what I undertand, I only need to use -no-g if I am using a parameter like -a? – mrjayviper May 23 '16 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.