1

I am trying to install jitsi-meet on a vm via automated script . However, the deb package prompts for a hostname. How can I set this value from a script? I have tried using debconf-set-selections, but I have been unable to set the value to anything but localhost. Here is what I am doing currently:

export DEBIAN_FRONTEND=noninteractive
echo 'deb http://download.jitsi.org/nightly/deb unstable/' >> /etc/apt/sources.list
wget -qO - https://download.jitsi.org/nightly/deb/unstable/archive.key | apt-key add -
debconf-set-selections <<< 'jitsi-meet-prosody jitsi-meet/jvb-hostname string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet jitsi-meet/jvb-hostname string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet-prosody jitsi-meet-prosody/jvb-hostname string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet jitsi-meet-prosody/jvb-hostname string "my.ip.address"';
apt-get install -y jitsi-meet

This works in the sense that it doesn't prompt me, however, the hostname is set incorrectly to localhost, not my.ip.address.

When I run debconf-show jitsi-meet before the script, the values seem to be right, but after the apt-get call, they are set to localhost.

I have been browsing these source files, but I haven't been able to make sense of it: here

Any idea how I can automate the entry of this value?

0

You should put an apt-get update after your addition to the /etc/apt/sources.list otherwise you are NOT getting the latest jitsi-meet from their repository, but whatever one is in the repositories for your distribution, and that one might not support all the options you are specifying.

Otherwise if jitsi-meet is using it's own debconf database (I believe the spec allows apps to use their own) then you would need to provide the path to that database when using debconf-* and see if that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.