2

Just built my new computer, but my problem is I have no sound. Can you help please? I'll run through what I have done so far...

I installed Debian and updated the BIOS OK. I also apt-get updated and apt-get upgrade-distro'd OK Here's my setup:

 michael@carbon:~$ inxi -Fxz  
 System:    Host: carbon Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4)  
            Desktop: Gnome 3.14.4 (Gtk 3.14.5-1+deb8u1) Distro: Debian GNU/Linux 8  
 Machine:   Mobo: ASUSTeK model: H170M-PLUS v: Rev X.0x Bios: American Megatrends v: 0704 date: 02/15/2016  
 CPU:       Quad core Intel Core i5-6600 (-MCP-) cache: 6144 KB  
            flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26487  
            Clock Speeds: 1: 3301 MHz 2: 3301 MHz 3: 3301 MHz 4: 3301 MHz  
 Graphics:  Card: Intel Device 1912 bus-ID: 00:02.0  
            Display Server: X.Org 1.16.4 drivers: fbdev,vesa,intel Resolution: 1920x1080@0.00hz  
            GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)  
            GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes  
 Audio:     Card Intel Device a170 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k3.16.0-4-amd64  
 Network:   Card: Intel Ethernet Connection (2) I219-V driver: e1000e v: 2.3.2-k bus-ID: 00:1f.6  
            IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>  
 Drives:    HDD Total Size: 3032.6GB (2.0% used) ID-1: /dev/sda model: ST3000DM001 size: 3000.6GB temp: 41C  
            ID-2: USB /dev/sdb model: microSD_RDR size: 32.0GB temp: 0C  
 Partition: ID-1: / size: 9.1G used: 4.9G (57%) fs: ext4 dev: /dev/sda2  
            ID-2: /home size: 2.7T used: 4.2G (1%) fs: ext4 dev: /dev/sda4  
            ID-3: swap-1 size: 34.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda3  
 Sensors:   System Temperatures: cpu: 66.0C mobo: 27.8C  
            Fan Speeds (in rpm): cpu: N/A  
 Info:      Processes: 191 Uptime: 3:09 Memory: 1871.2/15963.8MB Init: systemd runlevel: 5 Gcc sys: N/A  
            Client: Shell (bash 4.3.301) inxi: 2.1.28  
 michael@carbon:~$

Notice I am using the onboard sound, not a soundcard. Actually everything is onboard, the's only the mobo, no cards.
First I checked if I had sound as root, but I don't (BTW I am a member of group 'audio'):

 michael@carbon:~$ id michael  
 uid=1000(michael) gid=1000(michael) groups=1000(michael),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),108(netdev),110(lpadmin),113(scanner),117(bluetooth)
 michael@carbon:~$

Rythmbox is playing a track I know, and the volume is 100%.
Then I noticed, in Settings -> Sound, when I plug the headphones into the 3.5mm line-out socket on the back of the computer a device appears for sound output (it goes away and re-appears when I unplug and plug-in headphones, which I know work). The device is called: "Line Out - Built-in Audio" so I've checked all the devices, but that's the one I'm using to troubleshoot.

Test the speakers... left and right, both nothing.
Under the "applications" tab I made sure Rythmbox has volume set to 100% there too.

So I looked at the System Log, Xorg.O.log and I noticed the following lines...

 .  
 .  
 .  
 [    63.602] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event8)  
 [    63.602] (II) No input driver specified, ignoring this device.  
 [    63.602] (II) This device may have been added with another device file.  
 [    63.602] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event9)  
 [    63.602] (II) No input driver specified, ignoring this device.  
 [    63.602] (II) This device may have been added with another device file.  
 [    63.602] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event10)  
 [    63.602] (II) No input driver specified, ignoring this device.  
 [    63.602] (II) This device may have been added with another device file.  
 [    63.602] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event11)  
 [    63.602] (II) No input driver specified, ignoring this device.  
 [    63.602] (II) This device may have been added with another device file.  
 [    63.603] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event12)  
 [    63.603] (II) No input driver specified, ignoring this device.  
 [    63.603] (II) This device may have been added with another device file.  
 .  
 .  
 .

I think that's the root cause of my problem, but looking at the CD that came with the mobo, I saw there's a directory for linux drivers that contains a file saying "Note: Please update to the latest Linux Kernel for motherboard chipset and components support." This is what I expect because, as I understand it, Linux should support the hardware using generic methods, without special drivers required by Windows (although I don't know whether Debian supports an Asus H170M-PLUS - it is a relatively new mobo...?) This message saying use the latest version and all will be OK, reinforces my belief is should work.

I'd like to uninstall and re-install the modules (aka device drivers in Windows) but not sure what to do...

michael@carbon:~$ ls /lib/modules/$(uname -r)  
kernel  modules.alias  modules.alias.bin  modules.builtin  modules.builtin.bin  modules.dep  modules.dep.bin  modules.devname  modules.order  modules.softdep  modules.symbols  modules.symbols.bin  
michael@carbon:~$ ls /lib/modules/$(uname -r)/kernel/drivers/  
acpi  base   bluetooth  cpufreq  dma       firmware  hid    i2c   infiniband  leds   memstick  misc  net      pci   power     ptp   ssb  thermal      uio  vfio   virtio    xen  
ata   bcma   cdrom  crypto   edac      gpio      hv     idle  input       md     message   mmc   nfc      pcmcia    powercap  scsi  staging  thunderbolt  usb  vhost  w1  
atm   block  char   dca  firewire  gpu       hwmon  iio   isdn        media  mfd       mtd   parport  platform  pps   spi   target   tty          uwb  video  watchdog  
michael@carbon:~$  

I don't really know what I'm looking at there (or what I'm looking for), but there's nothing starting with "snd..." so what is there to uninstall?

root@carbon:/home/michael# alsactl init  
Found hardware: "HDA-Intel" "Intel ID 2809" "HDA:10ec0887,104386c7,00100302 HDA:80862809,80860101,00100000" "0x1043" "0x86c7"  
Hardware is initialized using a generic method  
root@carbon:/home/michael# lspci -v  
.  
.  
.  
00:1f.3 Audio device: Intel Corporation Device a170 (rev 31)  
    Subsystem: ASUSTeK Computer Inc. Device 86c7  
    Flags: bus master, fast devsel, latency 32, IRQ 139  
    Memory at f7040000 (64-bit, non-prefetchable) [size=16K]  
    Memory at f7020000 (64-bit, non-prefetchable) [size=64K]  
    Capabilities: [50] Power Management version 3  
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+  
    Kernel driver in use: snd_hda_intel  
.  
.  
.  

I'd like to try un-installing and re-installing, but don't know the commands or the module.
Still no sound.

 michael@carbon:~$ lspci -nn  
 .  
 .  
 .  
 00:1f.3 Audio device [0403]: Intel Corporation Device [8086:a170] (rev 31)  
 .  
 .  
 .

8086=Intel and a170=PCI sound, but "a170" is NOT found on the page listing PCI devices supported by debian. Could that be my problem?

Just rebooted to make sure nothing I have done has had any effect.
Still struggling with this one. How can "Line Out - Built-in Audio" be recognized by the system, but not have sound output?
Any ideas what to try next?

  • Try to install pulseaudio : aptitude install pulseaudio – GAD3R May 19 '16 at 11:25
  • Pulseaudio is there already. root@carbon:/home/michael# aptitude install pulseaudio No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used. root@carbon:/home/michael# – Michael May 19 '16 at 11:38
  • @GAD3R - Also, Pulseaudio is already running. root@carbon:/home/michael# pulseaudio W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified). E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: pa_pid_file_create() failed. root@carbon:/home/michael# – Michael May 19 '16 at 11:49
1

I assume you've checked all the volume levels in the sound preferences! pavucontrol may be useful to check the levels in more detail.

Given that you have quite recent hardware, you could try a more recent kernel, from the Debian backports:

echo "deb http://ftp.debian.org/debian jessie-backports main" > /etc/apt/sources.list.d/jessie-backports.list
apt-get update
apt-get -t jessie-backports install linux-image-4.5.0-0.bpo.2-amd64

(if you need firmware modules, add contrib and non-free to the first line — look in /etc/apt/sources.list for a model — and install the backported firmware packages too).

  • Amazing - I have installed and run pavucontrol and now, under the "output devices" tab, for built-in audio analog stereo, port "line out (plugged in), I can even see a bar-graph sound meter moving but still no sound. I will try backported firmware packages and let you know how I get on. – Michael May 19 '16 at 12:37
  • @stephen_kitt I carried out the instructions above and the machine will not boot up anymore. The messages were Loading, please wait... [5.959252] 1915 0000:00:02.0: firmware: failed to load i915/sk1_dmc_ver1.bin (-2) \n [5.959252] [drm:csr_load_work_fn [i915]] ERROR failed to load DMC firmware, disabling rpm. I used the Debian install CD to go into recovery more, reverted /etc/apt/sources.list.d/jessie-backports.list to its previous state, but aptget update/dist-upgrade show no updates, and the machine will not start. A complete reinstall of Debian is not necessary - but a quick fix! – Michael May 22 '16 at 2:29
  • In the grub menu you get while booting, there should be an "Advanced options for Debian GNU/Linux" entry which will allow you to boot with the previous kernel. You can then apt-get purge linux-image-4.5.0-0.bpo.2-amd64. Regarding the last sentence of your comment, if you want reactive support on terms you specify, feel free to buy a support contract from one of the many Debian consultants — this isn't the place for such demands. – Stephen Kitt May 22 '16 at 12:15
  • Version 4.6 of the kernel has much better support for Skylake, it might be worth trying again with that once it's available in backports. – Stephen Kitt May 22 '16 at 12:16
  • @stephen_kitt No demands here. I guessed an expert would be able to get out of it, but I didn't know Debian lets you boot into the previous kernel - thanks for the info, at least I know now. I did do a full re-install (no change) so I will try Skylake when I get the chance (I'm going away for 3 weeks). Just want to say thank you so much for the help. – Michael May 25 '16 at 4:13
0

As suggested, the issue was the motherboard architecture was too new. I installed the latest version of Debian Jessie after a delay of a few months and it worked right out of the box, as it normally does.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.