3

I am running CentOS 7, with RAID 1 (md) on the hard drives. I have the partitions set as shown below.

md0 -> root (sda1, sdb1)
md2 -> swap (sda2, sdb2)
md3 -> misc (sda3, sdb3)

on md3, I have disabled journaling. However, when my application writes to md3; I experience high I/O wait times (35+%).

The exact same setup on CentOS 6 gives me no I/O wait issues. I have tried disabling journaling on all partitions on CentOS 7, and changing mount options/ filesystem flags. But, to no avail.

CentOS 6 is using GRUB, CentOS 7 is using GRUB2

CentOS 6 --> 2.6.32-573.7.1.el6.x86_64

CentOS 7 --> 3.10.0-327.13.1.el7.x86_64


CentOS 6

grub.cfg:

title CentOS (2.6.32-573.7.1.el6.x86_64)
    root (hd0,0)
kernel /boot/vmlinuz-2.6.32-573.7.1.el6.x86_64 ro root=UUID=d8273070-760f-4728-b70c-0368be3ec612 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8
SYSFONT=latarcyrheb-sun16 crashkernel=128M KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
initrd /boot/initramfs-2.6.32-573.7.1.el6.x86_64.img

dumpe2fs output --> /dev/md3

Filesystem features:      ext_attr resize_inode dir_index filetype extent flex_bg sparse_super large_file huge_file uninit_bg dir_nlink extra_isize
Filesystem flags:         signed_directory_hash

CentOS 7

grub.cfg:

menuentry 'CentOS Linux (3.10.0-327.13.1.el7.x86_64) 7 (CentOS 7 RAID)' --class centos --class gnu-linux --class gnu --class os {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_msdos msdos
    insmod diskfilter mdraid1x
    insmod ext2
    set root='mduuid/afa918cd8b06e98111da7fa5baab386e'
    if [ x = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint='mduuid/afa918cd8b06e98111da7fa5baab386e' cbad6fd3-333c-4137-afce-9e1c8b9b75d2
    else
      search --no-floppy --fs-uuid --set=root cbad6fd3-333c-4137-afce-9e1c8b9b75d2
    fi
    linux16 /boot/vmlinuz-3.10.0-327.13.1.el7.x86_64 root=UUID=cbad6fd3-333c-4137-afce-9e1c8b9b75d2 ro crashkernel=auto  vconsole.font=latarcyrheb-sun16 rd.md.uuid=afa918cd:8b06e981:11da7fa5:baab386e vconsole.keymap=us rd.md.uuid=a0e564a7:cfc4a6b6:57b4f190:8e5734c7 rhgb quiet LANG=en_US.UTF-8
    initrd16 /boot/initramfs-3.10.0-327.13.1.el7.x86_64.img
}

dumpe2fs output --> md3

Filesystem features:      ext_attr resize_inode dir_index filetype extent 64bit flex_bg sparse_super large_file huge_file uninit_bg dir_nlink extra_isize
Filesystem flags:         signed_directory_hash

1 Answer 1

1

To close this one. Updating to kernel 3.10.0-327.36.1+ fixed the issue; with journaling still disabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .