12

I hate numlock. I have 'enable numlock on boot' disabled in BIOS. When I boot to windows, numlock is not on. When I boot into Linux and sit at the login screen, numlock is not on. When I enter my password and enter i3, numlock is on. Case-insensitive grep for 'num' in .i3/config is empty. What's going on?

2
  • 1
    What distribution are you running? What display manager are you logging into? If you select a different session type, is numlock turned on? May 18, 2016 at 21:19
  • 1
    I am so interested to know what you use scoll lock for if you have a full size keyboard, since there are dedicated arrow keys, home/del/pageup/page down keys right next to it. I wish scroll lock never existed. Aug 4, 2022 at 9:45

1 Answer 1

28

Since you did not specify much details about your system there's not much to go on.

I would recommend to download "numlockx", since I don't know which distro you are using I can't tell you how, but you should know how to install applications...

When numlockx is installed, just type this into your i3config: exec_always --no-startup-id numlockx off

I hope that solved your issue.

2
  • Yep, that's what I did a month ago when I had this issue, and it solved it. Jun 13, 2016 at 22:11
  • 2
    Thank you! I had the exact opposite problem (needing to enable numlock each time) and it solved it as well
    – Miku
    Dec 15, 2020 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .