6

I hate numlock. I have 'enable numlock on boot' disabled in BIOS. When I boot to windows, numlock is not on. When I boot into Linux and sit at the login screen, numlock is not on. When I enter my password and enter i3, numlock is on. Case-insensitive grep for 'num' in .i3/config is empty. What's going on?

  • 1
    What distribution are you running? What display manager are you logging into? If you select a different session type, is numlock turned on? – Gilles May 18 '16 at 21:19
13

Since you did not specify much details about your system there's not much to go on.

I would recommend to download "numlockx", since I don't know which distro you are using I can't tell you how, but you should know how to install applications...

When numlockx is installed, just type this into your i3config: exec_always --no-startup-id numlockx off

I hope that solved your issue.

  • Yep, that's what I did a month ago when I had this issue, and it solved it. – horse hair Jun 13 '16 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.