3

I upgraded my system from wheezy to jessie.  However, I am not able to boot using the latest kernel that was installed with jessie.  I get the following error:

Loading, please wait...
/init: conf/conf.d/resume: line 1 syntax error: unexpected "("
... Kernel panic - not syncing: Attempted to kill init exitcode=0x00000200
... 
... CPU: 1 PID: 1 Comm: init Not tainted 3.16.0-4-amd64 #1 Debian 3.16.7-ctk25-2
... Hardware name: Dell Inc. Precision Workstation T5400 ... BIOS A11 04/30/2012
...
...
...

Here are two photographs of the screen during the boot: 1 and 2.  Neither is perfectly clear; look at either one, or both, or neither, as you prefer.

I can boot with older kernel 3.2.0-4 using sysvinit from GRUB.

This is what I have tried so far:

  1. Upgrade installed a new path to swap in /etc/initramfs-tools/conf.d/resume:

     # cat /etc/initramfs-tools/conf.d/resume 
     # RESUME=/dev/mapper/isw_chjgibahbj_DMRAIDp5
    

    which didn't map to correct swap in /etc/fstab, so I fixed that.

  2. I don't have SELinux extensions installed, but I tried to boot with selinux=0 and it didn't work.

  3. My BIOS is the latest version.

I am guessing it has to do with RAID. I am using LVM on MDRAID mirror, so I am going to do more digging on my own, but I'm also putting it out there in case someone else can give me a quicker answer or point me in the right direction.

1
  • never mind. I forgot to run udpate-initramfs -u i can now boot
    – dynix
    Commented May 18, 2016 at 1:19

1 Answer 1

3

I forgot to run update-initramfs -u after fixing the swap in .../resume and and /etc/fstab

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .