3

I'm trying to set up a transmission server for use as a seedbox. I've done this before on an Ubuntu box, but this is the first time I've tried it on FreeBSD.

The default home directly for transmission from the FreeBSD package collection is /usr/local/etc/transmission/home. As this is on my small partition, I moved the contents of this directly to /home/transmission (on my large partition) and created a symlink from /usr/local/etc/transmission/home to /home/transmission.

I changed the ownership of both the link and the directory+contents to the transmission user, and then recursively set chmod 644 on the contents of /home/transmission. I chose 644 because I want my SSH user to be able to grab the contents of the /home/transmission/Downloads/ (so I can get the files to my home PC via SFTP).

The trouble is, transmission keeps resetting the directory permissions! See below:

[peter@haida ~]$ sudo ls -al /home/transmission
total 72
drwxr-x---  6 transmission  transmission   512 May 17 16:12 .
drwxr-xr-x  7 root          wheel         1024 May 17 03:11 ..
drwxr--r--  4 transmission  transmission   512 May 17 03:22 Downloads
drwxr--r--  2 transmission  transmission   512 May 16 03:34 blocklists
-rw-------  1 transmission  transmission  2885 May 17 16:08 dht.dat
drwxr--r--  2 transmission  transmission   512 May 17 06:16 resume
-rw-------  1 transmission  transmission  2226 May 17 16:08 settings.json
-rw-------  1 transmission  transmission   149 May 17 06:20 stats.json
drwxr--r--  2 transmission  transmission   512 May 17 03:21 torrents

Note that the /home/transmission folder (.) has permissions 750. The Downloads subfolder has permissions 744, which is what I want, however, as the parent directory is 750 I can't actually look in there as a non-privileged user.

I tried changing the default umask in settings.json to no effect (my settings file: http://pastebin.com/v83ikGrn). Any ideas?

  • You have to stop Transmission first (service transmission stop), change the settings.json umask, and start the daemon again. – Jynx Sep 22 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.