1

I am trying to copy WeChat database file called EnMicroMsg.db so I can view it in SQLite browser.

With my Nexus 7 tablet rooted and physically connected, the usb debugging checked I ran the following commands on cmd: adb devices which confirmed that my devices is connected, adb shell to enter the shell mode, su command to gain root, `cd /data/data/com.tencent.mm/MicroMsg/ and ls to see the directories

root@flo:/data/data/com.tencent.mm/MicroMsg # ls

first among the list is

6bb3ed9fac8c14c96ab852ea8fc570db

Then I changed to the directory 6bb3ed9fac8c14c89ab852ea8fc570db, and used ls command to list the directory content.

root@flo:/data/data/com.tencent.mm/MicroMsg/6bb3ed9fac8c14c96ab852ea8fc570db # ls

I found it listed among the results.

CommonOneMicroMsg.db
CommonOneMicroMsg.db.ini
EnMicroMsg.db
EnMicroMsg.db.bak
EnMicroMsg.db.ini
IndexMicroMsg.db
SnsMicroMsg.db

Having confirmed that it is located there. I exited shell mode and then tried pulling it by typing

C:\AndroidSDK\sdk\platform-tools>adb pull /data/data/com.tencent.mm/MicroMsg/6bb 3ed9fac8c14c96ab852ea8fc570db/EnMicroMsg.db

but the response I got was

remote object '/data/data/com.tencent.mm/MicroMsg/6bb3ed9fac8c14c96ab852ea8fc570
db/EnMicroMsg.db' does not exist

How do I pull this file?

  • there's a space before "EnMicroMsg.db" in your question; is that The Problem, or is it copy/pasta? – Jeff Schaller May 17 '16 at 17:26
  • @Jeff that is typo error. As you can see in the image the space isn't there. I will correct it in the question – e.kenny67 May 17 '16 at 17:38
  • 2
    Please don't post images. Instead copy and paste the text and format it with the {} button. Images are not searchable, whereas text is. Images may disappear over time as the hosting services change. – garethTheRed May 17 '16 at 18:02
  • adb is the UNIX debugger, initially written by Stephen Bourne and still in use on UNIX. I suspect, you refer to another program that accidentally uses the well known name adb, e.g. a google program. You could avoid confusion if you did clearly mention that you are not interested in the original. Thank you! – schily May 17 '16 at 18:42
  • @schily I'm sorry but I do not understand what you mean by "you could avoid confusion if you did clearly mention that you are not interested in the original". – e.kenny67 May 17 '16 at 19:18
1

Following Andrew Sun's suggestion in this stackoverflow answer, I installed adbd Insecure from Google Play.

The developer according to this link explained that the app gives root access in adb shell and allows access to system files and directories through adb push/pull, which exactly solved my problem.

After installation I was able to execute the adb pull command successfully outside adb shell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.