0

I have recently installed Arch Linux and GNOME 3 on my new laptop and have a problem whereby nm-applet is not showing in gnome-panel, unless I manually restart the NetworkManager daemon.

  • I am assuming that the applet doesn't show up after login? If so, a workaround is adding nm-applet to the Startup Programs, using gnome-session-properties. – tshepang Jan 6 '12 at 13:27
1

I found the answer with help of the Arch Linux Forums:

I tried to start the networkmanager daemon before the dbus daemon, which does not work. Changing the order solved the problem.

  • how to change the order or deamons running, with systetmd? I installed arch very recently and having the same problem, I coudn't find rc.conf to edit.. – pahnin Mar 8 '13 at 18:09
1

Another way is by adding to startup apps:

$ gksudo "/etc/rc.d/network-manager restart"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.