3

I have a empty file in home directory, when I run nano temp4 it gives me error Received SIGHUP or SIGTERM and does not open the file

@archlinux ➜  ~  ᐅ  nano temp4
    Received SIGHUP or SIGTERM
@archlinux ➜  ~  ᐅ  l temp4 
    -rw-r--r-- 1 edward edward 0 May 17 16:04 temp4
@archlinux ➜  ~  ᐅ  file temp4 
    temp4: empty

what could be the reason? This has been happening too often lately with many other files.

However, I can solve the problem by running echo > temp4 and then opening it with nano

(I am running Arch Linux. nano 2.5.3)

  • Use strace and auditd to better debug what system calls nano is making and where the signal is coming from. – thrig May 17 '16 at 14:12
  • 1
    I have encountered this problem also. Solved it after running sudo su before (Debian 9 stretch) . – grama Dec 20 '17 at 5:26

protected by Community Mar 18 at 23:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.