11

I use kali linux os , I have a problem with libcrypto.so.1.0.0 library

/Bureau/PacketTracer62Student/bin$ ./PacketTracer6 
./PacketTracer6: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
12

You need to install libssl1.0.0:

sudo apt-get install libssl1.0.0

For future reference, you can install apt-file to find this out yourself:

sudo apt-get install apt-file
sudo apt-file update
apt-file search libcrypto.so.1.0.0
3
  • 1
    I get this Package libssl1.0.0 is not available, but is referred to by another package. – Deepak Kamat Oct 6 '18 at 9:17
  • having the same problem on Centos, but could not find package for ssl1.0.0, Anyone knows answer for Centos? – Kemin Zhou Oct 22 '18 at 23:00
  • 1
    how install in centos 7? :O – Neftali Acosta Nov 13 '18 at 5:51
2

Using reinstall worked for me:

sudo apt-get install libssl1.0.0 libssl-dev --reinstall
2
  1. sudo nano /etc/apt/sources.list
  2. add deb http://security.ubuntu.com/ubuntu bionic-security main
  3. sudo apt update && apt-cache policy libssl1.0-dev
  4. sudo apt-get install libssl1.0-dev

source: https://raspberrypi.stackexchange.com/questions/101245/how-do-i-install-the-libssl1-0-0-package/112232#112232?newreg=b4deba3288294d1e82b88241d5d0c295

2

This is what finally worked for me in Kali 2021.1:

Downloaded 'libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb' from: http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb

installed it on Kali linux with:

dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.6_amd64.deb

I used amd64 package relevant to my arch. if you want a different architecture check here http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/

confirm it's installed with:

dpkg --list | grep -i libssl

you should see libssl1.0.0 in the installed list

1
  • yes ! I've forgotten than dpkg -i could workaround version issue of apt-get install when we want fix upgrade issue of an old application. – phili_b Jun 4 at 18:04
0

Just download the binary package file from here and copy the libcrypto.so.1.0.0 file to /usr/lib . That solves the problem!

2
0

Use below commands to fix this error error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

sudo apt-get install software-properties-common
sudo apt-add-repository -y ppa:rael-gc/rvm
sudo apt-get update
sudo apt-get install rvm
sudo apt install libssl1.0-dev
New contributor
Shubham is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • Welcome to the site, and thank you for your contribution. However, could you elaborate why installing the development headers ob libssl should solve the OPs problem? Also, why is rvm needed in this case? – AdminBee 7 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.