3

I have an external drive. When I just plug the drive into the PC, with a default /etc/fstab file, the OS just detects it and it's there in the Dolphin browser. I can select it, I can navigate to it on the command line, read/write/etc the files on it, etc.

I'm trying to mount the drive into my home directory so that Plex Media Server can access it. I've done this a million times before with this same drive no problem, on Linux.

I recently re-installed the OS and went to set up the drive, same as always. Again, this exact same configuration has worked in the past, on the same version of Linux (OpenSUSE Leap 42.1), on the same machine, with the same hard drive. I've added this entry

UUID=F474B7AA74B76DCC /home/craig/MediaDrive ntfs-3g defaults,nofail,permissions,auto 0 1

to /etc/fstab to mount the drive in my home directory. I get it mounted to /home/craig/MediaDrive. The first weird thing is that ls -l shows

d--------- 1 root  root   12288 May 16 18:33 MediaDrive

So then I go to set ownership and change permissions with

sudo chown -R 777 /home/craig/MediaDrive

and I get the error:

chmod: changing permissions of ‘MediaDrive’: No space left on device

The thing is, there's plenty of space left. There's over 300GB of space left. I'm pasting my df -h output below.

Filesystem      Size  Used Avail Use% Mounted on
/dev/sde1       1.9T  1.6T  316G  84% /home/craig/MediaDrive

It doesn't seem to be an inode issue; here is the output of df -i:

Filesystem      Inodes  IUsed      IFree  IUse%  Mounted on
/dev/sde1    331060948   4846  331056102     1%  /home/craig/MediaDrive

Again, this permissions issue only exists with the drive when I try to mount it in that location (in my home directory); otherwise when it's just at the default run/media/craig/My Passport location, it's fine. Reads, writes, etc.

How can I get my drive to mount successfully in my home directory?

  • It might help if you show the exact chmod command that you're using.  Also, you talk about two different ways of mounting your drive; please describe this.  Please do not respond in comments; edit your question to make it clearer and more complete. – G-Man May 17 '16 at 2:03
  • I added the information you asked for. Thanks. – user2223059 May 17 '16 at 2:16
  • 1
    can you give full df -lh output including OS partitions not just your mounted disk? (yes, update your question) – cuongnv23 May 17 '16 at 2:40
  • @user2223059: I put your question into a blender and put the pieces back together in what seems to me to be a more sequential narrative.  Please check it and fix any errors that I made.  And now, I’m afraid that I probably won’t be able to help you any further; I’m stumped.  Good luck. – G-Man May 17 '16 at 2:53
  • Thanks for the help. Honestly, I'm at the point where if no one comes up with anything, after work tomorrow I'm going to just wipe and reinstall from scratch. Maybe there's something weird and random that got screwed up at some point? who knows. – user2223059 May 17 '16 at 3:17
0

Umount it, and make the mountpoint more permissive. Sometimes this is relevant... maybe it is in your case because using a different mountpoint has different results. Compare the permissions on those 2 directories for more info.

Check man ntfs-3g for options, and use them, for example:

mount -o fmask=664,dmask=775,uid=1000,gid=1000 /dev/sde1 /home/craig/MediaDrive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.