0

I am trying to perform filesystem extraction on viber app. my findings show that viber contains a folder named databases which contained files of interest, namely, Viber_messages, Viber_data and Viber_call_log.db. Hence first I made sure that my android device is connected by using the command "adb devices", then typed "adb shell". Then I decided to search for the aforementioned files by typing "find / -name" along with the names of the folder and files one after the other but the response I got was "not found". I also tried to root it by typing su but I got the same response

What am I doing wrong? I have attached an image of what I didenter image description here

2 Answers 2

0

You can try syntax variations until your keyboard wears out. find is not found by the shell you've started, and that has to be fixed first.

I don't recall having seen find in ADB, so I would first make sure you actually do have that command and decide on a different strategy if you don't. You could e.g. try to grep the output of ls -R

2
  • @Anton this link alvinalexander.com/unix/edu/examples/find.shtml shows that the command " find " exists. However it probably should be used after rooting. However, when I typed the command " su " I still got the response " su : not found". Does it mean my phone is not rooted?
    – Mercy E
    May 16, 2016 at 15:21
  • no the 'not found' means that the command is not found, neither find nor su are on your system. Also see this post on Stack Overflow
    – Anthon
    May 16, 2016 at 15:23
-2

If your phone is rooted (which based on your statement, "I tried to root it by typing su" I'm gonna guess it isn't but I'm not sure), you can just install BusyBox and a terminal emulator to have more of the linux commands you're probably expecting or used to. This will really only allow you to copy to a connected USB or SD card and is basically done in an app from the Play Store.

Link to the general adb page:
http://developer.android.com/tools/help/adb.html
You should explore this and just developer.android.com in general to get more familiar with Android because there are some pretty important differences between it and your usual Linux. (Like the fact that you don't have root access by default and don't have access to all directories)

Also read:
http://www.linuxtopia.org/online_books/android/devguide/guide/developing/tools/android_adb_copyfiles.html

This explains a way to copy files from/to a device. The relevant lines being:

adb pull <remote> <local>

In the commands, and refer to the paths to the target files/directory on your development machine (local) and on the emulator/device instance (remote).

Here's an example:

adb push foo.txt /sdcard/foo.txt

1
  • Yes my tablet wasn't rooted. I rooted the tablet and then running the su command I was able to look for the files with the find coomand
    – Mercy E
    May 17, 2016 at 16:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .