1

In accordance with this post I have added

xmodmap ~/Documents/looseScripts/Xmodmap

to my ~/.xinitrc. I have also created an item in "startup applications" with the command:

bash -c "xmodmap ~/Documents/looseScripts/Xmodmap"

, and set the delay to 60 seconds. However, when I startup my right command key is not remaped. However, pasting either of these commands directly into the terminal remaps the right-command key and and achieves the desired effect. How do I make either of these commands actually take effect on startup?

I doubt that it's relevant, but here is ~/Documents/looseScripts/Xmodmap:

clear Mod4
clear Control
keycode 134 = Control_R NoSymbol Control_R
keycode 37 = Control_L NoSymbol Control_L
keycode 108 = Alt_R Meta_R Alt_R Meta_R
keycode 206 = NoSymbol Super_L NoSymbol Super_L
keycode 133 = Super_L NoSymbol Super_L
keycode 207 = NoSymbol Hyper_L NoSymbol Hyper_L
add Control = Control_R
add Control = Control_L
add Mod4 = Super_L

Current workaround:

I have added the text from inside the ~/.xinitrc to my bashrc, so that it runs every time I start up my terminal. For some reason it does not have any trouble running here.

1

It seems that simply using the delay option in startup items does not work. I have do exactly as this post says and use:

bash -c "sleep 30;xmodmap ~/Documents/looseScripts/Xmodmap"

instead of a delay. However, this isn't very elegant, as I have no idea why this works. As such, I'm hoping to accept an answer that is a bit less hacked-together.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.