1

Similar to this question, I cannot apt-get update my machine.

I've tried everything I could Google: adding the bad key, deleting my /var/lists/thingy, apt-get clean, deleting Chrome.

But I keep getting the error below. Is there a more nuclear option? Like deleting the update manager and redownloading it or something?

Ign http://archive.ubuntu.com trusty/universe Translation-en_ZA                
Fetched 23,8 MB in 1min 41s (234 kB/s)                                         
W: GPG error: http://packages.linuxmint.com rosa Release: The following signatures were invalid: BADSIG 3EE67F3D0FF405B2 Clement Lefebvre (Linux Mint Package Repository v1) <root@linuxmint.com>
W: GPG error: http://archive.ubuntu.com trusty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: Failed to fetch http://extra.linuxmint.com/dists/rosa/main/binary-i386/Packages  Hash Sum mismatch

Update:

I've tried this:

  • removing google chrome
  • adding keys: sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 3EE67F3D0FF405B2

-

sudo rm -r /var/lib/apt/lists
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get clean
sudo apt-get update
  • and everything in here

Update 2

  • apt-key list

    pub 1024D/437D05B5 2004-09-12 uid Ubuntu Archive Automatic Signing Key sub 2048g/79164387 2004-09-12

    pub 1024D/FBB75451 2004-12-30 uid Ubuntu CD Image Automatic Signing Key

    pub 4096R/C0B21F32 2012-05-11 uid Ubuntu Archive Automatic Signing Key (2012)

    pub 4096R/EFE21092 2012-05-11 uid Ubuntu CD Image Automatic Signing Key (2012)

    pub 1024D/0FF405B2 2009-04-29 uid Clement Lefebvre (Linux Mint Package Repository v1) sub 2048g/0F346519 2009-04-29

    pub 1024D/3E5C1192 2010-09-20 uid Ubuntu Extras Archive Automatic Signing Key

    pub 4096R/46D7E7CF 2009-05-15 uid GetDeb Archive Automatic Signing Key

    pub 4096R/2C52609D 2015-07-14 uid Docker Release Tool (releasedocker)

    pub 1024R/28949509 2010-08-22 uid Launchpad Gwendal Le Bihan

    pub 1024D/7FAC5991 2007-03-08 uid Google, Inc. Linux Package Signing Key sub 2048g/C07CB649 2007-03-08

    pub 4096R/D38B4796 2016-04-12 uid Google Inc. (Linux Packages Signing Authority) sub 4096R/640DB551 2016-04-12 [expires: 2019-04-1

  • apt-cache policy

    Package files: 100 /var/lib/dpkg/status release a=now Pinned packages:

  • Please edit your question and show us the commands you tried. How exactly did you add what key? What was the output of whatever command you used to add it? What is /var/lists/thingy? – terdon May 16 '16 at 12:10
  • Please paste the output of apt-cache policy into the question. Also, the output of apt-key list. – Faheem Mitha May 16 '16 at 17:16
  • 1
    The "Hash Sum mismatch" error is typically gotten rid of by deleting the corresponding file from /var/lib/apt/lists. It would start with extra.linuxmint.com_dists_rosa... The GPG errors don't actually cause anything to fail, afaik. – Faheem Mitha May 16 '16 at 17:18
  • Same problem discussed : forums.linuxmint.com/viewtopic.php?t=217501 – Severus Tux May 19 '16 at 15:30
  • Could you try running sudo apt-get update -o Acquire::http::No-Cache=True to make sure it is not a server side problem? This is basically what was done to resolve the problem in the thread linked by @SeverusTux – jschlichtholz May 19 '16 at 16:20
0

Without more info, all I can suggest is:

Try installing another copy of the same OS release, updating it (apt-get update, upgrade, and dist-upgrade), and then copying the suspected relevant parts of it to the broken machine (after making backups of course). For example copy /etc/apt/ and /var/lib/apt/ and see if apt-get update will work then.

  • Yeah, I'm giving up. The link @jschlichtolz shared basically says there's no solution. I'll switch to Ubuntu as they have an entire StackExchange forum for support for stuff like this. Though I'll miss Cinnamon. – Richard May 24 '16 at 8:49
  • @Richard if you think it's just Mint that's broken and only use it for Cinnamon, then just install Cinnamon on another distro... – Peter May 24 '16 at 20:59
  • Although theoretically that should work people in other forums complain about compatibility issues. The problem with Linux is there're always weird little errors. So I think it would be better to just stick to Ubuntu standard - easier for support. – Richard May 25 '16 at 6:08
  • 1
    I once had a similar error that had to do with my corporate proxy/webfilter blocking specific downloads (while allowing browsing the directories). try accessing/ downloading the URLs directly through a web browser or curl and see how that goes. – nagu May 25 '16 at 18:58
0

Run this command for the GPG error : sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 3EE67F3D0FF405B2 40976EAF437D05B5. Then for the Hash Sum mismatch try running these commands : sudo rm -rf /var/lib/apt/lists/* and sudo apt-get update

  • Thanks, I've done that. It was listed in the link in my question I think – Richard May 24 '16 at 12:54
  • In that case i see 3 options that you can do : 1. No longer use apt-get :use aptitude. 2.reinstall apt-get aptitude purge apt-get and aptitude install apt-get 3. Like in the Peter's answer , reinstall the OS. – LXGA May 24 '16 at 13:51
  • I tried these commands trying to understand what you said above, but got the same error at the end: 1) sudo apt-get install aptitude 2) sudo aptitude purge apt-get 3) sudo aptitude install apt-get 4) apt-get update – Richard May 25 '16 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.