1

I am having an error starting corosync on a cluster member:

May 16 00:53:32 neftis corosync[19741]:  [MAIN  ] Corosync Cluster Engine ('2.3.4'): started and ready to provide service.
May 16 00:53:32 neftis corosync[19741]:  [MAIN  ] Corosync built-in features: dbus systemd xmlconf snmp pie relro bindnow
May 16 00:53:32 neftis corosync[19741]:  [MAIN  ] parse error in config: No interfaces defined
May 16 00:53:32 neftis corosync[19741]:  [MAIN  ] Corosync Cluster Engine exiting with status 8 at main.c:1278.
May 16 00:53:32 neftis corosync: Starting Corosync Cluster Engine (corosync): [FALL�]
May 16 00:53:32 neftis systemd: corosync.service: control process exited, code=exited status=1
May 16 00:53:32 neftis systemd: Failed to start Corosync Cluster Engine.
May 16 00:53:32 neftis systemd: Unit corosync.service entered failed state.
May 16 00:53:32 neftis systemd: corosync.service failed.
May 16 00:54:06 neftis systemd: Cannot add dependency job for unit firewalld.service, ignoring: Unit firewalld.service is masked.
May 16 00:54:06 neftis systemd: Starting Corosync Cluster Engine...
May 16 00:54:06 neftis corosync[19773]:  [MAIN  ] Corosync Cluster Engine ('2.3.4'): started and ready to provide service.
May 16 00:54:06 neftis corosync[19773]:  [MAIN  ] Corosync built-in features: dbus systemd xmlconf snmp pie relro bindnow
May 16 00:54:06 neftis corosync[19773]:  [MAIN  ] parse error in config: No interfaces defined
May 16 00:54:06 neftis corosync[19773]:  [MAIN  ] Corosync Cluster Engine exiting with status 8 at main.c:1278.
May 16 00:54:06 neftis corosync: Starting Corosync Cluster Engine (corosync): [FALL�]
May 16 00:54:06 neftis systemd: corosync.service: control process exited, code=exited status=1
May 16 00:54:06 neftis systemd: Failed to start Corosync Cluster Engine.
May 16 00:54:06 neftis systemd: Unit corosync.service entered failed state.

Here is my config on the three nodes but it is failing just in netfis which I added recently.

totem {
    version: 2
    secauth: off
    cluster_name: cluster-osiris
    transport: udpu
}

nodelist {
    node {
        ring0_addr: isis.localdoamin
        nodeid: 1
    }

    node {
        ring0_addr: horus.localdoamin
        nodeid: 2
    }

    node {
        ring0_addr: netfis.localdoamin
        nodeid: 3
    }
}

quorum {
    provider: corosync_votequorum
}

logging {
    to_syslog: yes
}

I am running a pacemaker, corosync, pcs cluster on CentOS 7.1 64. bits.

I searched on internet but It is not clear what is going on.

Could you help me?

2 Answers 2

3

Do the hostnames you have listed in your Corosync configuration resolve correctly? I would start by verifying that.

# host isis.localdoamin

Since, "domain", appears to be spelled incorrectly (or in a language I am ignorant of), I am going to guess that command fails? ;-)

Also, you could use the short hostname (without ".localdomain") or the IP addresses of the interfaces you'd like Corosync to bind to instead.

2
  • Ah, "doamin" turns out to be Spanish!! Try the shortname or IP address; it definitely sounds like it can't find an interface to bind to. May 17, 2016 at 23:13
  • You are right. I tryied with neftis.localdomain and I could not reach it. in my /etc/hosts file I have this line 10.10.10.230 neftis.localdomain Pretty strange, isnt it? Thank you! May 18, 2016 at 15:53
0

Had this error message because of proxmox added a record on loopback ip for my container hostname in /etc/hosts like that:

# --- BEGIN PVE ---
127.0.1.1 pgmaster
# --- END PVE ---

I have one more record in hosts for this name. Commented out loopback record and it is ok now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.